Model 100 make flash error

TL;DR: About 20-30 minutes ago, I used “make flash” to flash the default firmware to my Model 100, just to make sure this worked. It did. I then modified the keymap in the .ino file and did “make flash” again. Now I see this error:

To update your keyboard's firmware, hold down the 'Prog' key on your keyboard.  (When flashing starts, you can release it.)

When you're ready to proceed, press 'Enter'.

# Earlier Model 100 firmware didn't implement 1200bps touch
# If we have a device serial port available, try to trigger a Kaleidoscope reset
dfu-util 0.11

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2021 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

dfu-util: No DFU capable USB device available
Error during Upload: Failed uploading: uploading error: exit status 74
make: *** [flash] Error 1

This is strange, as it would seem to have nothing to do with me changing the .ino file…?

I do notice that the “prog” key doesn’t flash when I hold it down now, although the process still continues when I press enter.

Solved - evidently the version of the firmware on github contains the error I read about in a different thread (forget which one) where basically you have to hold the prog key as you plug in the keyboard. I did that, then pressed “enter” on a different keyboard and the firmware flashing worked.

Is there a fix planned for this issue? It seems to have been introduced by whatever’s in the repo as of today, as I did not need to use this workaround when I did my test flash of the firmware a couple hours ago. Not a huge deal since I have an easy workaround, but still seems like unintended behavior.

Flashing via the Arduino IDE or make are not as easy as we want them to be, we’re working on ways to make the process smoother.