Timing of [prog] key press when uploading firmware

I have experienced a number of errors while uploading firmware sketches (scary red warning bar and red error messages in the Arduino IDE), which seem to be largely avoidable by changing the “prog” key press timing slightly from the official docs.

The Edit-A-Keymap page of the GitHub / wiki says:

  1. While holding down the prog key, click on the right arrow in the sketch window menu bar to compile compile [sic] and install.

If I instead first press the right arrow, and then hold down the prog key, I have a much higher success rate.

This behavior is occurring on a 2013 rMBP running High Sierra. The timing change was suggested by Jesse.

Huh! I had the opposite experience with my macbook pro and Sierra 10.12.6

Just tried both methods and both worked, so I changed the docs. Thanks!

1 Like

I perhaps should have mentioned that I had initially performed maybe a dozen error-free firmware uploads using the “prog-then-arrow” timing.

No idea why the behavior of my system seems to have changed, but for now it is a highly repeatable preference for “arrow-then-prog”.

Given the variation in my own experience, I didn’t think it correct to suggest a change to the official docs*, but wanted to share this problem and corrective action, in case it might be helpful.

*other than they typo :slight_smile: (Also, thanks to you Jennigma for your work on the docs and forum)

Re-edited it to this:

Click on the right arrow in the sketch window menu bar then hold down the “PROG” key to compile and install. If you get an error, some systems seem to work better if you hold down the “PROG” key and then press the arrow. We aren’t sure why some systems work better in different order yet, so try both and do whatever works better for you. :slight_smile: