Arduino-Boards repository replaced with Kaleidoscope-Bundle-Keyboardio


(tiltowaitt) #1

I’ve had a working method for building and updating the firmware for some time now. To update, I navigate to Arduino/hardware/keyboardio/avr and run make update-submodules.

When I ran it this time, however, I was presented with a bunch of “delete” messages for a number of plugins in libraries, and now building my firmware with make flash presents the following error message:

BOARD_HARDWARE_PATH="/Users/tiltowait/Programming/Arduino/hardware" /Users/tiltowait/Programming/Arduino/hardware/keyboardio/avr/libraries/Kaleidoscope/bin//kaleidoscope-builder flash Building output/Model01-Firmware/Model01-Firmware (0.0.0-gv1.22-27-g561b-dirty) ... Board model01 (platform avr, package keyboardio) is unknown make: *** [flash] Error 1

(Yes, I’m using a non-standard directory for Arduino. I have aliases set up, which has let things work perfectly in the past.)

If I try to pull everything from git again with make update-submodules, I’m told there’s no rule to make that target.

Did something change recently?


(JP) #2

Probably, I can’t get my one shot modifiers (and a few other things to work either). 1.92.0-beta?


(Gergely Nagy) #3

Yes, we transitioned from Arduino-Boards to Kaleidoscope-Bundle-Keyboardio as the parent repo that pulls in everything else. If you were using Arduino-Boards, see the README for instructions how to migrate to the new repo.

Can you open an issue on GitHub, with a pointer to your sketch (if possible), and the error messages you get? I tried my best to make the recent source rearrangement as painless as possible, if there are upgrade issues left, I’d like to fix those ASAP.

Thanks! :slight_smile:


(tiltowaitt) #4

Thanks. I was able to get it working again.