Error compiling firmware


(Troy Dahnert) #1

Followed instructions at https://github.com/keyboardio/Kaleidoscope/wiki/Install-Arduino-support-on-Windows
It’s my first time running arduino ide. I downloaded from windows store on a windows 10 machine. According to my understanding of the instructions I did not install usb drivers. Receiving error “board model01 (platform avr, package keyboardio) is unknown” when clicking checkmark to verify. Have retried steps using other version numbers and other ports. Only three com ports are selectable. I have tried all three. Not sure what else to try.


(Jeremiah Tuttle) #2

I had the same problem. I downloaded Arduino IDE version 1.6.10 from [https://www.arduino.cc/en/Main/OldSoftwareReleases#previous] , uninstalled the latest IDE (1.8.7), installed the older version, then proceeded from Step 2 of the very link you used. Everything went fine from there. Hope this helps. (real credit goes to my genius brother for solving this one).


(Jesse) #3

I’ve managed to reproduce this with Arduino 1.8.7 and Kaleidoscope 1.23, but not with 1.91-beta. Does that match what you folks are seeing?


(Jesse) #4

Ok. I think I got it. 1.92 is now out. I’d love to know if it fixes things for you.


#5

I had the exact same issue; I tried installing the 1.91-beta on Windows and could no longer compile, even after I rolled back to an 1.90-beta and reinstalled Arduino 1.8.7 from scratch. I can confirm the 1.92 beta fixes the problem on Arduino 1.8.7. Thanks for fixing the issue Jesse.


(Linh Le) #6

I have the same issue described above. I’m using Window 10, Arduino 1.8.7 with 1.92.0 beta installed. What can I do?


(Gergely Nagy) #7

There should be an 1.93 beta out, which should not have this issue anymore. Can you try upgrading?


(Linh Le) #8

Thank you! It’s a little bit strange because I don’t have the option to install 1.93 version.


(Gergely Nagy) #9

Did you install Arduino from the Windows Store, or using their own installer? If you did the former, I would recommend removing it, and installing via the official installer. The Arduino in the Windows Store has issues updating the list of boards for some odd reason.


#10

One thing that may be worth looking into as well is that changing Compiler Errors -> All in the Arduino IDE causes a segmentation fault when compiling the latest firmware for me on Windows 10. Changing back Compiler Errors -> Debug builds and works as expected.