Can't upload firmware to keyboard with Arduino IDE


#1

Hi there, I just got my Keyboardio and tried to shift some keys around following the instructions on https://github.com/keyboardio/Kaleidoscope/wiki/edit-a-keymap

Instead of replacing the ___ with Key_Escape, I tried Key_Q just so I could quickly confirm the key changed, and then move on to make the changes I wanted…

Everything worked fine and the prog key was replaced with ‘q’. I then tried to change it back, and switch other keys but uploading no longer worked. It would just hang with the bar fully green, then resulting in the error below.

And now I can’t hold the prog button while uploading because that just spams q. Not sure how to return to the default settings. I even tried uninstalling the Arduino IDE (I installed with installer, not the one from the Windows store) and reinstalling, for some reason all the settings were all the same from the previous install, but it still wouldn’t work.

Arduino: 1.8.8 (Windows 10), Board: "Keyboardio Model 01"

WARNING: Category 'Debug' in library Kaleidoscope-Hardware-Virtual is not valid. Setting to 'Uncategorized'
Sketch uses 24756 bytes (86%) of program storage space. Maximum is 28672 bytes.
Global variables use 1408 bytes (55%) of dynamic memory, leaving 1152 bytes for local variables. Maximum is 2560 bytes.

avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
Found programmer: Id = "þ"; type = ¸
    Software Version = i.

the error message got cut off via copy/paste…


(Gergely Nagy) #2

The Prog key may spam q, but it will still act as a prog key, focus a window where spamming Q doesn’t hurt, and that should help.

If it does not, then disconnect the keyboard, press and hold the Prog key, plug it in (still holding Prog!), then flash it, holding Prog until the flashing process starts.


#3

Lol! I can’t believe I didn’t try that, but that totally worked! Thanks for the help!!