Error while flashing


I just got my Model 01 and I’m trying to flash algernon’s firmware.
Arduino IDE is installed, installed keybordio board, downloaded the example firmare and I able to flash the keyboardio.

I’ve cloned locally algernon’s repository, entered it, typed make setup followed by make flash, hold prog and press enter

There is an error but it still flashes the board and the keyboards acts weirdly after. What do I do wrong?

here is the error : 
    Sylvains-MacBook-Pro:algernon sylvain$ make flash
BOARD_HARDWARE_PATH="./lib/hardware" ./lib/hardware/keyboardio/avr/libraries/Kaleidoscope/bin//kaleidoscope-builder flash
Building src/algernon 0.0.0 into /var/folders/np/x4646kv15l19sh8l_q21j6gw0000gn/T//kaleidoscope-sylvain/sketch/12898088092-algernon.ino/output...
- Size: firmware/algernon/algernon-0.0.0.elf
  - Program:   26560 bytes (92.6% Full)
  - Data:       1261 bytes (49.3% Full)

To update your keyboard's firmware, hold down the 'Prog' key on your keyboard,
and then press 'Enter'.

When the 'Prog' key glows red, you can release it.

    2019-10-30 21:40:45.376 system_profiler[73578:3758455] SPUSBDevice: IOCreatePlugInInterfaceForService failed 0xe00002be
    2019-10-30 21:40:48.630 system_profiler[73587:3758592] SPUSBDevice: IOCreatePlugInInterfaceForService failed 0xe00002be
    Connecting to programmer: .
    Found programmer: Id = "CATERIN"; type = S
        Software Version = 1.0; No Hardware Version given.
    Programmer supports auto addr increment.
    Programmer supports buffered memory access with buffersize=128 bytes.

    Programmer supports the following devices:
        Device code: 0x44

    Sylvains-MacBook-Pro:algernon sylvain$

Are you on OSX Catelina? Because that has a bug that affects all Arduino devices, the Model01 included. As far as I am aware, they’re working on pushing a fix.

Thank you for your response.
I should have mentioned that I’m still on Mojave 10.14.6, staying away from Catalina as it breaks too many things at the moment.
I’m on a MacBook Pro 13 2017. I tried with the USB-C to USB-A + Official Apple USB-C adapter, and also with a USB-C to USB-C cable I own, same result.

So, I am able to flash with Arduino IDE and the stock firmware only. Where could I find a tutorial on How to flash with CLI on a Mac?

If you’re able to flash the stock firmware with the Arduino IDE, but custom firmware won’t work with the IDE, that suggests that maybe there’s an issue with the custom firmware you’re flashing. @algernon’s custom firmware likely requires a very specific version of Kaleidoscope to work right, but that’s something he’ll be able to address much better than I can.