How to checkout code from github and use the Arduino IDE to compile?

I have a bit of a particular setup with my development system/platform. I’m running Windows, but spend a good portion of my time in cygwin. I have a lot of my tooling setup in cygwin for my day-to-day tasks. I’ve tried cloning the github repos for the Model01 firmware and libraries, and had a fair struggle with that. Given that my git global setting was core.autocrlf=true, the checkout would create CRLF on all the script files, and make would fail with EOL error messages. Trying to change my git config on a per-repo basis is a recipe for frustration as there are so many submodules, and I would need to configure the config for each repo individually.

I ended up changing my global config, but that impacts my other projects now. Is there a reason why a .gitattributes file is not included in each repo forcing LF eols considering they are so important?

Once I finally managed to get make to run, I get the following error message:

$ make
BOARD_HARDWARE_PATH="~/dev/Projects/thirdparty/keyboardio/hardware/" ~/dev/Projects/thirdparty/keyboardio/hardware//keyboardio/avr/libraries/Kaleidoscope/bin//kaleidoscope-builder build-all
Building ./Model01-Firmware 0.0.0-g
v1.22-67-g4299 into /tmp/kaleidoscope-erbe/sketch/17451448556812141-Model01-Firmware.ino/output...
FindFirstFile C:\home\erbe\dev\tools\Arduino\hardware: The system cannot find the path specified.
make: *** [/home/erbe/dev/Projects/thirdparty/keyboardio/hardware//keyboardio/build-tools/makefiles// build-all] Error 1

I’m not sure where it is getting the C:\home\erbe\dev\tools\Arduino\hardware from, nor do I know how to override that value so that it points to my $BOARD_HARDWARE_PATH. I’ve tried to read through the Makefile but can’t seem to find where it requires this path, nor what the expected path should be.

I then tried to compile it from the Arduino IDE. But when I open the sketch in the IDE and try to compile it, I get the following error message:

Model01-Firmware:17:26: error: Kaleidoscope.h: No such file or directory

compilation terminated.

exit status 1
Kaleidoscope.h: No such file or directory

At this point I’m a little stuck. I haven’t done any programming with an Arduino before and not entirely sure how to configure library locations/etc. How can I use the IDE to compile the code I’ve d/led from github?