Migrating from Chrysalis to Kaleidoscope

I decided to take the plunge and try using Kaleidoscope on my Model 100. I followed the Getting Started instructions and it seemed to go smoothly.

I’ve still got my Chrysalis layout, albeit without colours or some features (e.g. double tapping shift no longer functions as a shift lock).

But when I load Chrysalis again, it says “Reading from device” and then presents me with a blank screen. I guess I should have printed out my Chrysalis layout before installing Kaleidoscope…

Anyhow, that leaves me with two questions:
(1) How can I start from scratch and get Chrysalis working again? (I’ve tried to factory reset but that gives me the blank Chrysalis screen…
(2) What’s the best way to transition to Kaleidoscope? Do I need to type the keymaps in by hand for each layer? Which plugins do I need to reactivate the various features in Chrysalis?


I answered my own question 1 - unplug, hold the prog key, start Chrysalis. Factory reset with latest firmware version…

Key question now: how do I get the LEDs working again? In other words, what do I need to do to the default Kaleidoscope firmware in order for the LED colors in Chrysalis to work?

(Currently, I get no LEDs at all. I’ve tried commenting out
// DefaultLEDModeConfig.activateLEDModeIfUnconfigured(&LEDOff);
but still no LEDs.
I also tried adding Kaleidoscope-LED-ActiveLayerColor but that didn’t do anything either)

found a solution to that to the LED problem - reinstall Chrysalis