Mouse Scroll Wheel speed - too fast

I have assigned the mouse scroll wheel to keys. When I press the key I was expecting to get “a” scroll, like when I scroll one click with a real mouse-wheel. Instead the scrolling is way too fast and in that form hardly usable. I am on Windows 11, using Chrysalis with a model 100 if that matters.

I have not set it on my sketch, but there is a MouseKeys.setScrollInterval() that sets the intervals between mouse scroll reports. It defaults to 50ms, or 20 per second. In my case, it seems to be very close to what my scroll wheel does on my trackball, but I suppose different pointing devices may be using different functions in the OS to do scroll.

Windows 11 has settings for scrolling. I have mine set to Roll the mouse wheel to scroll multiple lines at a time, and the number of lines is close to the minimum.

I am not sure how it interacts with my Elecom Mouse Assistant 5, since the scroll speed is set around the middle there, and Flying Scroll Revolution Speed is also set to the medium, with number of revolutions set to 1. I do not expect these settings to be exactly the same on other devices, however.

Thanks, changing the settings in the operating system will indeed work to slow down the scrolling, but then the number of scrolled lines with one mouse-wheel click will be smaller than I’d want. I tried around and found a working compromise, but would prefer if the scrolling from the keyboard could just be slowed down, maybe some slight delay to hold down the key before it continues to scroll. But possibly I will make the keys free again anyways to get space for other functions/ characters. Scrolling with the arrows from the home-row (which I have been using since 2008) works already quite o.k. in most situations.

Did you try to modify the setting in Chrysalis:
Preferences → My Keyboard → Scrolling speed ?

Thanks for the tip. I had not seen that option! I changed from 50 to 100 ms and it much better now. Scrolling is a bit jumpy although and not totally smooth. That is the downside, but it is usable now, which it wasn’t before! :slight_smile: