My Qukeys are Broken

(David Aue) #1

I pulled the latest Kaleidoscope-Bundle-Keyboardio and got my sketch compiling again but my Qukeys are broken. I’m using the DualUse macros in the keymap but I only get the shifted function even when using a normal keypress.

[QWERTY] = KEYMAP_STACKED
(___,           Key_1, Key_2, Key_3, Key_4, Key_5, Key_LEDEffectNext,
 Key_Backtick,  Key_Q, Key_W, Key_E, Key_R, Key_T, Key_Tab,
 Key_PageUp,    CTL_T(A), ALT_T(S), CTL_T(D), SFT_T(F), Key_G,
 Key_PageDown,  Key_Z, Key_X, Key_C, Key_V, Key_B, Key_LeftGui,
 Key_LeftParen, Key_Backspace, Key_Delete, GUI_T(Escape),
 XXX,

 M(MACRO_ANY),       Key_6, Key_7, Key_8, Key_9, Key_0, LockLayer(NUMPAD),
 Key_Enter,          Key_Y, Key_U, Key_I, Key_O, Key_P, Key_Equals,
                     Key_H, SFT_T(J), CTL_T(K), ALT_T(L), Key_Semicolon, Key_Quote,
 Key_PcApplication,  Key_N, Key_M, Key_Comma, Key_Period, Key_Slash, Key_Minus,
 GUI_T(Tab), Key_Enter, Key_Spacebar, Key_RightParen,
 XXX),

MyModel1.ino (12.3 KB)

EDIT: I just tried this with the latest Chrysalis experimental firmware (compiled by me or flashed from Chrysalis). Set a “Modifier when held” in Chrysalis, and am seeing the same behavior…always getting the modifier.

(Michael Richters) #2

There have been quite a few updates to Kaleidoscope, including some major Qukeys fixes, since the version in the latest Kaleidoscope-Bundle-Keyboardio. Have you tried using the master branch of Kaleidoscope?

(David Aue) #4

That works. Thank you.

1 Like