Normal flashing won't work, port lost and keyboard crashed


I’m following the standard instructions for flashing the keyboard and I select the right port, hold the prog key but get this error:

Arduino: 1.8.5 (Mac OS X), Board: “Keyboardio Model 01”

Build options changed, rebuilding all
Archiving built core (caching) in: /var/folders/px/g08dnmzs0fjb3kzzdlyk2pfh0000gn/T/arduino_cache_573405/core/core_keyboardio_avr_model01_6907a5c3cb29daa309377897623470bc.a
Sketch uses 18888 bytes (65%) of program storage space. Maximum is 28672 bytes.
Global variables use 1932 bytes (75%) of dynamic memory, leaving 628 bytes for local variables. Maximum is 2560 bytes.
Low memory available, stability problems may occur.
Couldn’t find a Board on the selected port. Check that you have the correct port selected. If it is correct, try pressing the board’s reset button after initiating the upload.

After this the port is gone from the menu and I have to unplug the keyboard to get it to work again.

Any hints?

I’ve now noticed that the keyboard “crashes” (LEDs go out, unresponsive) even if I don’t press ‘prog’, just instruct the IDE to upload firmware.

Chris, did you manage to get this working? I just tried the same on a Mac, but I’m not seeing the same issue.

When the keyboard enters “upload mode”, the prog key should turn red. Do you see this?

Flashing seems more reliable when I unplug the keyboard, hold prog, and then plug it back in right before the build finishes and the upload starts.

1 Like

Off topic: How do you produce those prog-key inline images?





[Footnote: I didn’t know either, but I seem to be a good guesser. :wink:]

1 Like

@cyrossignol: I do not see the prog key turn red at all, neither does it help to hold prog while plugging in.

Have you tried to upload firmware via command-line? I think it employs a different system for finding the correct port; maybe it will work.

Yes. You need to be holding in the prog key or the keyboard won’t let you flash the firmware. (This prevents against malware flashing your keyboard without your consent.)

1 Like

Hmm… from what I understand, the prog key should turn red when the keyboard is reset while holding that key (either by a signal from software or power cycle). If it doesn’t, there may be a problem with the bootloader or the driver is missing/misbehaving (someone please correct me if I’m wrong).

Something to try to narrow down the problem:

  • Run this command in a terminal:
    sleep 5; /usr/sbin/system_profiler SPUSBDataType
    You’ll have 5 seconds to perform the next steps:
  • Unplug the keyboard
  • Wait a second or so
  • Hold prog and plug the keyboard back in
  • Keep holding until the command finishes. It will output some information about USB devices.

Look for an entry in the output for the Model 01. If you see it, there may be a issue with the IDE. If you don’t see it, we may have a problem with hardware/drivers. Post the output back here if you’re not sure.

1 Like

Just a regular HTML tag. Some sites style it nicely, which makes it especially useful here.

Good guess :slightly_smiling_face:

1 Like

If you unplug the keyboard, then plug it in again while holding prog, and it doesn’t light up red, something is wrong with the hardware and/or bootloader.

@cyrossignol I get no particular error message from running your command:

Product ID: 0x2301
Vendor ID: 0x1209
Version: 1.00
Serial Number: Ckbio01
Speed: Up to 12 Mb/sec
Manufacturer: Keyboardio
Location ID: 0x14140000 / 10
Current Available (mA): 500
Current Required (mA): 500
Extra Operating Current (mA): 0

I will try the command line next. Have tried a different USB socket btw.

Are there instructions to install and use the arduino command line on a Mac with the Model 01? I can only find the IDE instructions.

The instructions for building/uploading from the command-line are in the README for the Model 01 firmware.

If you don’t have XCode developer tools set up already, run the following to download some programs needed for this process:

xcode-select --install

Then, follow the instructions for Mac to try to build and upload the firmware. If this works, you can then start customizing the sketch at Documents/Arduino/Model01-Firmware/Model01-Firmware.ino.

I had the same issue as @ctlaux. I was making tweaks to my keymaps, and all of a sudden it lost the connection.

For me, unplugging and re-plugging in didn’t work. BUT, I was able to work around by:

  1. Unplugging
  2. Hold down prog
  3. Plug in (while still holding prog). The prog key is illuminated red.
  4. Start the upload in Arduino.

Thanks to @cyrossignol for the suggestion.

1 Like