[solved] Adding an new layer breaks Model 01’s firmware

After finally finding the time to apply the fixes as kindly described in this thread, I started playing around with my Model 01’s firmware again.

Then I run into the following problem, which I don’t understand:

Arduino: 1.8.19 (Linux), Board: "Keyboardio Model 01"

Model01-Firmware:313:1: error: macro "PER_KEY_DATA_STACKED" requires 66 arguments, but only 64 given
 ) // KEYMAPS(
exit status 1
macro "PER_KEY_DATA_STACKED" requires 66 arguments, but only 64 given

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


Invalid library found in /home/hook/.arduino15/packages/keyboardio/hardware/avr/2022.2.19183125/libraries/Kaleidoscope-LEDControl: no headers files (.h) found in /home/hook/.arduino15/packages/keyboardio/hardware/avr/2022.2.19183125/libraries/Kaleidoscope-LEDControl

Given the number, I counted the entries of keys in my newly added layer, but all the other layers also have 64 keys. So that’s not it.

This is the version that works:

And this is the commit that breaks it:

What am I doing wrong?

Managed to fix it. There was a silly typo. Fixed now in