Using the keyboard in your UEFI Bios

I’m wondering if anyone else is having issues while working in their UEFI/BIOS boot screens? Here’s what I’m getting while looking at the UEFI/BIOS when booting this PC. The Model 01 is using commit:717733ad6471d27b108d97f0400d1538836d49b5 (flipped a couple thumb keys around)
It happens in both “Enable Legacy USB” on and off modes.

fn+l (right arrow) - moves selection up
pgdn - moves selection down
pgup - moves selection to next screen
fn+pgdn (end) - moved selection to previous screen

it should be doing the fn+hjkl (aka VIM movement bindings) to do the selection previous/down/up/right

It feels like the keyboard is being detected in some strange mode when in the UEFI/BIOS screens. Anyone else seeing this behavior? What mode does the keyboard setup as when booting the PC?

This is most likely because the keyboard is using N-key Roll Over (NKRO), while some BIOSes only support the older 6KRO. @jesse did some work on this around the time of the PVT run, if I remember correctly, but I don’t know how far he got.

That’s REALLY weird. What I’d actually be expecting is for it to not work at all in the BIOS because we don’t have ‘legacy’ boot protocol mode support turned on yet.

What PC and BIOS is this? That may help me debug a bit.

This is something I consider to be a firmware deficiency, but what you’re seeing is better than I thought possible right now. I thought there was an open ticket about this, but there was not.

Boot Protocol mode and negotiation is not implemented. · Issue #220 · keyboardio/Kaleidoscope · GitHub now tracks this.

1 Like

Gigabyte ga-x79-xp4 i7-3930k so not overly old

In testing out the laptops, it seems laptops only like to use their internal keyboards and not any attached keyboards.

I’m not able to use the keyboard in the BIOS or for entering BitLocker passphrase in the boot. It works with other keyboards, including my TEK. This is pretty annoying, since now have to boot my laptop detached from my docking station (which is behind my monitors), enter the BitLocker passphrase, and then attach it to the docking station.

Looking forward to get issue #220 implemented! :wink:

I have a dual boot system and I use the F8 key when booting to popup a HDD dialog (Asus Z87 motherboard). This does not work with the Model 01. The function key is not being detected. The Fn-Bksp does allow me to get into the BIOS and I can select the boot drive from there. I tried mapping the F8 key to a key in the Numlock layer, but that didn’t work either.

Update:
The assignment to the Numlock Layer actually does work. I guess I was too late when I tried it the first time. It’s just the Fn-8 that doesn’t work.

Not sure whether this is related, but my Model 01 doesn’t produce input when logging into macOS (10.13) for the first time after booting up.

1 Like