Bringing Model 01 up to date

I’ve been using the Model01 since late 2017 and managed to come up with a layout I like in a couple of months. Once I managed to set that up on the keyboard I only made small edits, mostly just using the command line to compile and flash. I didn’t feel necessary to keep up with the latest upstream firmware or get into Chrysalis as the ancient firmware worked just fine.

Having received my Model100 and having managed to port my Model01 fw over to it I now want to refresh my Model01 with the new firmware backported from the Model100 one. I am, however unable to make Chrysalis connect to the Model01. My suspicion is that this is due to the ancient firmware my M01 is running.

Is there documentation available somewhere to make the Model01 Chrysalis-compatible?


Thank you. I might have been somewhat unclear in the OP however. I’m not really looking to edit the fw via Chrysalis, I’m just looking to be able to upload custom firmware through it. But when I click “Connect” in Chrysalis with the M01 connected (and working), the connection times out. That’s what I’m looking to solve.

Ah, I see. At the moment, connecting through Chrysalis requires at least FocusSerial, EEPROMSettings and EEPROMKeymap enabled on the firmware for the Model01. That’s a bug, it shouldn’t, it should guide you to the firmware update screen if it can’t detect those. Additionally, the trick that works on the Model 100, to hold PROG while plugging in, and then connect with Chrysalis - that also doesn’t work on the Model 01, due to a different bug.

I’m working on resolving those ASAP, but for now, the easiest is likely to enable the mentioned three plugins.

Ah, I see, thank you. I’m wondering how I will be able to get those plugins onto the m01. Let’s see if command line flashing works or whether I’ll run into the same problem that made me do fw uploads to the m100 via Chrysalis…

; make flash
Using Kaleidoscope from /Users/ikoszo/imre/oss/Kaleidoscope

Used platform  Version Path
keyboardio:avr 1.6.11  /Users/ikoszo/imre/oss/Kaleidoscope/.arduino/user/hardware/keyboardio/avr
arduino:avr    1.8.5   /Users/ikoszo/imre/oss/Kaleidoscope/.arduino/data/packages/arduino/hardware/avr/1.8.5

To update your keyboard's firmware, hold down the 'Prog' key on your keyboard.  (When the 'Prog' key glows red, you can release it.)

When you're ready to proceed, press 'Enter'.

# If we have a device serial port available, try to trigger a Kaliedoscope reset

I hold prog, press enter but nothing happens :frowning:

I tried cloning GitHub - keyboardio/Model01-Firmware: The "standard" Keyboardio Model 01 Firmware sketch. and following the instructions there but I’m running into the same issue - I hold down prog, press enter then nothing happens.

Reading up on some old threads and emails I came across GitHub - keyboardio/avr_keyscanner: Keyscan controller, with LED drivers using an ATtiny88 and GitHub - keyboardio/Factory-Firmware-Builds: Built copies of factory firmware for Keyboardio keyboards. - @algernon is there a chance that updating the former and flashing the latter could help?

Managed to do this with make flash on Revert "Merge pull request #1283 from tlyu/focus-timeouts" · keyboardio/Kaleidoscope@d9f0743 · GitHub :tada: