Can't upload to Model 100 with arduino

I am doing the first thing for uploading normal file of Model 100.
And it said this:

在C:\Users\PC\AppData\Local\Arduino15\packages\keyboardio\hardware\gd32\2022.9.15235615\libraries\Kaleidoscope-LEDControl: no headers files (.h) found in C:\Users\PC\AppData\Local\Arduino15\packages\keyboardio\hardware\gd32\2022.9.15235615\libraries\Kaleidoscope-LEDControl裡找到無效的程式庫

I did check that link, there is only 1 file named “” there.
And I search those folders besides it, most of them have at least a “src” folder in it.
So how could I do? Thank you for your help!

And another question is, is it possible to both use arduino and Chrysalis?
I mean coding some with arduino then upload, then do the same with Chrysalis.
I guess the answer is NO, but worth a try :).

The answer is a YES. As long as the plugins necessary for Chrysalis are included in the sketch, Chrysalis will work, and such a setup is fully supported, even encouraged.

The following document outlines which plugins are required:

How did you start setting Arduino up?

1 Like
Basically all the same like those link, the only different is I choose each step for Model 100 instead of Model 01.

Don’t know how, I copy some files from the “Kaleidoscope-master”(which I don’t remember where I downloaded it) into the LEDControl folder.
And now the original question disappear…
But another one is out:

Warning: Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release
No DFU capable USB device available

I did try connected the usb into other holes of my computer, but still does’t work now.

A few funny, I found how to upload from arduino.
But after that, the Chrysalis can’t use now…
Chrysalis ask me to upload, but with holding “prog” key, it still show error after about 3 mins.

I am going to sharing my solution here, if someone need.
It’s my using time line:

  1. Using Chrysalis-0.11.1-portable
    It works, even sometimes it randomly assign random colors to each key.

  2. Trying using Arduino. After following the guide, check “upload” while holding prog key, it didn’t work, like what I posted here.

  3. After searching lots of things on the internet, the first

Kaleidoscope-LEDControl: no headers files (.h)

is actually not a problem. Somewhere the designer said so. You will see this error message in Arduino, but it will still upload correctly.

And the other question,

No DFU capable USB device available

Found the solution in other Arduino projects, some of them need to “hold some key” WHILE connecting THE USB-C into it.
I tried take out the usb-c, holding the prog key, then connect it.
Then my windows 10 told me there are DFU connected to my computer.
Finally I successful upload Arduino into the keyboard.

  1. After uploaded, Chrysalis-0.11.1-portable can’t use anymore.
    And I found that if I use the same method (connect the usb-c while holding prog key), Chrysalis will ask me to upload the newest version of keyboard.
    But the problem is, it still can’t upload successful.
    After many tried, seems like the 0.11.1 version is not that stable(some people said that).
    I went to download the 0.11.0 version, and somehow it can upload!
    And even more, after this upload, the 0.11.1 version can work normally again!

Sorry another question now…
How can I build an *.firmware file?(I guess with Arudino?)
Seems like there are that much common sense I don’t know, and the guide doesn’t explain so…

Now I add two line to set mouse speed in Arduino *.ino, which could work(but will also remove those custom setting with Chrysalis).
And after open Chrysalis it will ask me to upload again, which will remove my setting from Arduino too.