Chrysalis issue - only layer 0 shown

Hi,

just started using my Atreus and I am trying to add the combination of ctrl+alt+4 to get, €.
I want to add this to Layer 1’ but when loading Chrysalis I ony seem to have the option to update layer 0.
How do I add the multiple layer options?
Screenshot vs the readme screenshot for clarity.

image

Does it also have the warning at the top that reads:

Chrysalis no longer supports configurations containing a mix of hardcoded and EEPROM layers. If this is a feature you need, we’d love to hear more about your use case.

I flashed the latest firmware to my Atreus but it is somehow not compatible with the latest version of Chrysalis.

Maybe related to this issue ?

If all your layers were empty, none of them were shown…

Does the new version fix this ?

Thanks, I did have that warning.
I’ve tried the previous release of Chrysalis and that works.

Same here. 0.7.9 works good.
0.8.0 only shows Layer 0 (even with 0.8.0 firmware).
I thinks this is a bug ?!

Most likely. It is also interesting that at first Chrysalis 0.8.0 was working fine for me with 0.7.9 firmware except for this bug. Then I decided to upgrade the firmware to 0.8.0 too, but then it stopped working entirely. I can add and stuff to the shown empty Layer 0, but those customizations doesn’t seem to get uploaded to the keyboard itself.

I’m using Win 10 on a HP desktop. Upgraded to Ch8 with 7.9 firmware and all was well. So I took the plunge (knowing I could always revert) and upgraded the firmware to 8.0.
Everything is still working; all levels are showing and I just made a change on Level 3 (Zwift level); the change took effect and everything seems normal.

I think we’ll need to explain this better in the UX, but if you click the layer #1 row on the table on top of the sidebar, that’ll show you layer 1.

I posted a very similar problem as a bug on the Chrysalis project in GitHub. The maintainer was kind enough to reply and let me know that it is indeed a bug…though not exactly what you (or I) thought.

The problem is that the 0.8.0 release accidentally omitted a button that shows the empty layers in addition to those that have assignments for the selected key. This bug was fixed in the 0.8.1-snapshot release of Chrysalis, which worked fine on my Atreus.

I’d recommend you download the 0.8.2-snapshot version (the current latest version) and give it a try.