Editing shortcuts when in NumPad layer?


(Shriramana Sharma) #1

I’d like to know people’s experience/preferences in using common editing shortcuts when in NumPad layer. The ones that come to mind which would be useful even when locked in to pure numerical input are Undo, Redo, Cut, Copy, Paste, Find, Select All.

Keeping the left half of the NumPad transparent would probably help with most of these when in the QWERTY layout, but there are other layouts around and people like @algernon who have said they don’t use the traditional ZXCV shortcuts.

I personally have cursors keys additionally mapped on the left half of my NumPad layer and so am thinking of just adding LCTRL(Key_Z) etc to some keys I have available. But before that I’d like to have people’s thoughts on this.

Have people used the dedicated Key_Undo, Key_Cut, Key_Copy, Key_Paste, Key_Find keycodes? (And what is Key_Again? Is it Redo? Or should I do Shift+Key_Undo for Redo?)


#2

They don’t work. At least Cut, Copy, and Paste don’t (the reason being “that they are OS dependent”). You have to use LCTRL(Key_C) and so on, but it does not make any difference.

I’ve mapped the cut, copy, and paste shortcuts to my base layer on PgUp and PgDown and find they work really great for repetitive cutting/copying/pasting text, but for anything non-repetitive I use the default ones, because I don’t like my hands leaving home row.


(Shriramana Sharma) #3

Three shortcuts to two keys?


#4

TapDance for copy and cut.


(Tré Ammatuna) #5

That’s an interesting thought, I like it! (and may just have to steal that… :wink: )


(Shriramana Sharma) #6

Hello people. Mapping PgUp/PgDn to cut copy paste isn’t an option for me since I deal with a larger number of graphical characters in Indic scripts. And that doesn’t address the issue of other shortcuts.

I’d still like to hear what @algernon and others who don’t use ZXCV shortcuts do when in the Num layer.


(Gergely Nagy) #7

If I’m on my layer with numbers, and need to copy / paste, I switch layers. I need to do that anyway because my cursor keys are mapped to the same physical keys as some of my numbers - on a different layer. :slight_smile: