Error installing Model 100 Arduino board

I tried installing the Arduino environment on my work laptop (MBP M1 Max) after successfully installing it on my personal M2 Air, but am getting the following error when following the instructions in

Downloading packages
Installing keyboardio:xpack-arm-none-eabi-gcc@9.3.1-1.3
keyboardio:xpack-arm-none-eabi-gcc@9.3.1-1.3 installed
Installing keyboardio:xpack-openocd@0.11.0-1
keyboardio:xpack-openocd@0.11.0-1 installed
Installing keyboardio:dfu-util@0.11.0-arduino3
Failed to install platform: keyboardio:gd32.
Error: 13 INTERNAL: Cannot install tool keyboardio:dfu-util@0.11.0-arduino3: testing local archive integrity: testing archive size: fetched archive size differs from size specified in index: 79057 != 78971

This happens both on the IDE and the CLI (make setup)

I have the same problem. Seems arduino has updated the dfu-util with a larger exec and a different hash. I’ve been able to work around it by editing the package_kaleidoscope_master_index.json to at least get it to install. But it doesn’t seem to work in any event. The flash stage completes but the keyboard doesn’t have an update firmware.

Indeed, Arduino updated something that’s never supposed to change, breaking new installs. I’ve just pushed up fixes to use their new versions of things.

1 Like

Thanks @jesse. That did fix the Arduino IDE scenario. However, Kaleidoscope’s make setup still fails with the same error.

To fix make setup, you’ll probably need to blow away the .arduino directory inside the Kaleidoscope checkout. (or I’ve missed an update)

It seems it is still not working:

Building in quiet mode. For a lot more information, add 'VERBOSE=1' to the beginning of your call to /Library/Developer/CommandLineTools/usr/bin/make
Error during build: Platform 'keyboardio:avr' not found: platform not installed
Platform keyboardio:avr is not found in any known index
Maybe you need to add a 3rd party URL?
Config file written to: /Users/pedropombeiro/src/
Downloading index: package_index.tar.bz2 downloaded
Downloading index: package_kaleidoscope_devel_index.json downloaded
Downloading packages...
arduino:avr-gcc@7.3.0-atmel3.6.1-arduino7 downloaded
arduino:avrdude@6.3.0-arduino17 downloaded
arduino:arduinoOTA@1.3.0 downloaded
arduino:avr@1.8.6 downloaded
Installing arduino:avr-gcc@7.3.0-atmel3.6.1-arduino7...
arduino:avr-gcc@7.3.0-atmel3.6.1-arduino7 installed
Installing arduino:avrdude@6.3.0-arduino17...
arduino:avrdude@6.3.0-arduino17 installed
Installing arduino:arduinoOTA@1.3.0...
arduino:arduinoOTA@1.3.0 installed
Installing platform arduino:avr@1.8.6...
Configuring platform....
Platform arduino:avr@1.8.6 installed
Tool arduino:avr-gcc@7.3.0-atmel3.6.1-arduino7 already installed
Tool arduino:avrdude@6.3.0-arduino17 already installed
Downloading packages...
keyboardio:avr-tools-only@0.0.1 downloaded
Installing platform keyboardio:avr-tools-only@0.0.1...
Configuring platform....
Platform keyboardio:avr-tools-only@0.0.1 installed
Downloading packages...
keyboardio:xpack-arm-none-eabi-gcc@9.3.1-1.3 downloaded
keyboardio:xpack-openocd@0.11.0-1 downloaded
keyboardio:dfu-util@0.11.0-arduino3 downloaded
keyboardio:gd32-tools-only@0.0.1 keyboardio:gd32-tools-only@0.0.1 already downloaded
Installing keyboardio:xpack-arm-none-eabi-gcc@9.3.1-1.3...
keyboardio:xpack-arm-none-eabi-gcc@9.3.1-1.3 installed
Installing keyboardio:xpack-openocd@0.11.0-1...
keyboardio:xpack-openocd@0.11.0-1 installed
Installing keyboardio:dfu-util@0.11.0-arduino3...
Error during install: Cannot install tool keyboardio:dfu-util@0.11.0-arduino3: testing local archive integrity: testing archive size: fetched archive size differs from size specified in index: 79057 != 78971
make: *** [install-arduino-core-kaleidoscope] Error 1

@MalarJuggler - So sorry about that! My fault. Give it another try now?

Looks good now @jesse, thanks!