Error on running Chrysalis 0.11.9 on Win7

I just got my Model 100 and it’s beautiful! I downloaded Chrysalis 0.11.9 and tried to run it but I got the attached error.

Chrysalis install error

How can I get this to work? This is on Win7.

I’m afraid Chrysalis will not work on Win7. It’s an Electron application, and Electron appears to require Windows 10 minimum. But even if it would start up, Windows prior to Win10 required third party drivers to be able to communicate over USB serial in a way Chrysalis requires, and those were… difficult to install (I never succeeded).

I’m confused - it worked fine on Win7 when I was using it for the Model01 and Atreus, before I upgraded.

What happened? Can I use an older version for the Model100?

I just checked and it looks like I was running 0.7.9 before, but it didn’t recognize my Model100, so I upgraded.

Hrm… Looking further into the issue, it seems Electron does support Win7 somewhat. Are you on 32 or 64 bit Win7?

If you’re on 64 bit win7, can you try the binaries from here? Looking at the Electron changelog, there are a few Win7-related fixes in more recent versions of it, so perhaps upgrading from Electron 17 (used in official builds) to 21 (in the PR above) may help?

I am on 64-bit. I just tried that binary and still get the error.


Since 0.7.9 works fine on Win7, there must have been a change made in between 0.7.9 and 0.11.9 that caused it to stop working. So maybe an earlier version will work. What is the earliest version of Chrysalis that supports the Model100?

0.9.0 is the earliest that supports the Model 100, but support there is… flaky at best. Flashing, for example, will likely not work at all.

Between 0.7.9 and 0.11.9, we went from Electron 7.1 to 17.x, quite a big leap (0.9.0 is also using Electron 17, by the way). Our build tooling also changed quite a lot. There’s over 1500 commits inbetween, too… I don’t think I’m able to help you much. :frowning:

The problem is actually very recent. I was able to narrow it down. 0.11.0 (and all earlier versions I tried) works on my Win7 machine, and 0.11.1 (and all later versions) does not.

Would I run into any problems going forward using 0.11.0?

Yeah, I could not get flashing to work on 0.11.0.