Anyone suddenly unable to connect a model 100?

I was using a custom-build sketch, trying to get my model 100 to work with Chrysalis. I was able to do that after many tries, and it even included a couple of resets to factory. Once I got this fully dialed in, I compiled to binary and saved everything on my local git repository. I then did a bunch of work on my model 01. I did not get to a point where the model 01 was ever able to connect to chrysalis, but since all my macros, leds, and keys were behaving exactly as I wanted, I considered myself satisfied, and saved the configuration to my model 01 to a different branch in my local git.
This morning, I figured I need to synchronize my two model 100s, so I went back to my model 100 branch, compiled and uploaded my sketch to the first model 100, tested a couple of things, and disconnected it once done. Then I tried connecting my second model 100. Much to my dismay, Windows complains that it does not recognize the USB device!
I tried using Chrysalis, but it does not recognize the device, even if I try to put it on programming mode (Windows still gives the same error). Even when I got the mapping completely messed up due to EEPROM contents, I had always been able to connect either model 100 to the computer, and then return it to factory condition, and proceed with my flashing.

Is there an FAQ for this? Or did I somehow get my one-month-old Model 100 to fail?

I bought two so I could have one serve as a backup if/when the old model 01 fails and cannot be used for work. All I wanted was to make sure that the same firmware is running on both model 100 keyboards.

I tried using a second computer that was not involved on the development, but it also complains that the device does not work.

Any help greatly appreciated.

If you hold in “Prog” while connecting your keyboard, you should be able to flash a replacement firmware to your device without ever booting into your broken sketch.

I tried that, and it did work on many occasions before, on both of my model 100s.

However, Chrysalis does not find this particular keyboardio anymore. Windows stopped recognizing it as a valid USB device, which seems to be the one requirement to be able to do anything with it.

I know that it should not be a device driver issue because the same computer is running another model 100 that had the same sketch on it that was working. I was creating a new sketch that fixed one thing on OneShot that I had submitted a PR to include. I had flashed both model 100s and the model 01 with similar (the model 01 having a different sketch than the others due to the same sketch on avr exceeding the total amount of program storage space available). Other than that, and the switches, everything else is the same.

One detail: I can put the keyboard that is not recognized as a valid usb device by the computer in programming mode, despite the fact that it is not recognized by any of my computers.

Is there any way to troubleshoot why this keyboardio does not connect to my computers? It was operating fine for about a month.

–Luis Nakano

One quick update: I found this link:

and tried to follow the first step to see if that would fix my issue, but this still failed to connect to my computer after the machine was rebooted with the changes to the registry.
I also saw come comment about the USB-C port being dirty, so I checked with a magnifying glass and blew some canned air on it.
Still no success.

(We believe this is a hardware defect and are working with Luis to get him a replacement )

1 Like

This was a hardware defect. Jesse sent me a picture of the USB protection curcuit, and it looked extra-crisp. I just installed the replacement board, and I was able to reprogram it without any issues.