Model 100 firmware hick-up out of nowhere and keyboard sometimes not responding

I sometimes have problems with the model 100. One time I started Chrysalis (on Windows 11) and my original 3 layers where not existing any longer. Instead there were 6 layers existing with random stuff on some keys. I thought I made a screenshot, but seemingly not. I made (another time) a reset and restored a backup which fixed that problem.

Another time I wanted to connect from Chrysalis to the keyboard and an error message “Communication timeout”. Replugging the keyboard cured that.

This keyboard is frustrating. It keeps eating time and does not work like it is supposed to do! I am using the keyboard each day for about 15 minutes to get accustomed to it (and a new layout which I am learning), but from time to time the keyboard goes crazy.

Yesterday I was typing and did not get the expected keys. When I opened Chrysalis I found that again the firmware got scrambled up, without any interaction or “strange” things on my side.

I just have the keyboard connected to the PC. I think that should be fine!? But somehow the keyboard firmware goes crazy from time to time!

I then opened a backup of my working configuration and uploaded the via Chrysalis. That fixed the problems.

Today I wanted to type and again had problems that keys do not react or do not respond in a timely manner. After I kept pressing a key a few times the character repeated endlessly. This time I could stop that by pressing another key. When I had similar problems before I even needed to unplug the keyboard.

I do not see any significant progress. When can we expect Chrysalis to offer similar functions like the competition? And more important when can we expect a firmware which runs rock-solid, like I have to expect from a keyboard (driver)!???

I see that I am not the only one with such problems, but I wonder how many actually use the M100 and are fully satisfied and how many accept that it is buggy and how many are already fed up or getting closer to giving up that keyboard?

I have the impression that this keyboard is so close to a great keyboard, but on the other side misses on getting it really robust, having the needed functions (easily accessible without the need to learn how to write firmware code) and misses documentation. It also misses some final touches like an Ethernet cable with a sensible length, an option to tilt the keyboard without raising it too much (Octofeet are a great idea, but for many will be not the best solution, because the keyboard is getting too high – it is already a tad on the high side).

If you can supply more detail about this problem, I might be able to help find the source and fix them. In particular, it would be helpful to know what keys you have defined in your keymap that are involved (in particular, things like “secondary actions” or SpaceCadet or one-shot keys could potentially be the source of the problem). If you’re using a custom firmware sketch, that would also be good to know.

I can sympathize with you. I fall into the “already fed up” category, having bits and pieces of the keymap I coded into the firmware overwritten or corrupted. I have only used Chrysalis to load custom firmware and clear EEPROM, never to make changes to the keymap but it seems like Chrysalis tries to store my last keymap, or at least parts of it, and use those bits and pieces to overlay the new firmware that I just compiled and loaded. The last straw was in early November when I uploaded a new revision of firmware that I had been working on and the M100 reverted to QWERTY, although I have never compiled a QWERTY firmware, only Colemak. Where did that come from? I put the keyboard in a closet and have not taken it out since. I keep checking the forums to see if there have been any breakthroughs in Kaleidoscope features and maybe a firmware install utility so that I do not have to even have Chrysalis installed. At this point I would really prefer a port to QMK.

I can only speak for myself. I have two model 100 keyboards. I have only made changes with Chrysalis. With my previous model 1 I manually setup firmware. I am pretty much using out of the box with some minor key changes.

The one I have never had any problems. I use it all day every day at work. Nothing ever is wrong.

The other I use at home and sometimes I do have an issue where it suddenly is repeating keys or missing keys. I have found unplugging and replugging in seems to fix it. My setup at home is a bit more complicated where I have a built in USB-C hub in my monitor and it can switch between my personal desktop and my work laptop. I only seemed to have issues with the desktop and not the work laptop so I mostly thought it was something related to either the setup or something there. It has only been a few times so have not gotten much farther.

As someone who really loves the keyboard and lurks on reading this forum, the git hub issues and tries to follow along with the code, I would say from my outside opinion it does seem that trying to add more advanced features to Chrysalis in someways hurting the user experience as it is adding things that are not explained well and there are several sets of instructions not all up to date and not all user friendly (example, the number used to determine the start LED mode). I think all the contributors are extremely technically skilled and working to get the best solution, but things are breaking as they change (such as the mix-ups between keymaps stored in code and eprom and the eprom layouts changing causing chaos). Again, I think everyone is doing their best and its a small group, but I can understand and sympathize with people who just want a fully working keyboard out of the box. Good documentation is hard.

1 Like

[been travelling and sick after that, so finally can answer]

Hello Michael,

my keyboard still randomly acts strangely and does not react to keystrokes or keeps on repeating keys in some sort of “trying to catch up” manner. I have only made very minor changes to the layout (swapped a few keys like Ctrl and Shift) and do not use any one-shot-key or spaceCadet. I have only used Chrysalis, so should not have messed up the firmware by accident. The only secondary action defined is the g-key when hold down to act as Alt.

The only not standard thing, which as I understood from Jesse, is that my keyboard is connected to a USB-hub which is connected to an integrated hub in a display. Well important to note that all other devices connected to this hub (including other keyboards) work without any problems or strange hickups. Only the Model 100 goes crazy!

@ klackityklak and randomman
Thanks for sharing your experience. I am getting a bit closer to ditch the keyboard and try to find an alternative. The problem is that the model 100 is really a nice keyboard as such and has unique features I like. Too bad that the experience is spoiled by those problems – and me getting the feeling that progress is not being made or at very slow rates. :frowning:

I have two tests to suggest:

  1. Try connecting the keyboard directly, and see if you still get delays. If so, we eliminate the USB hub as the source of the problem.
  2. Try switching from NKRO to 6KRO report protocol. If your sketch is unmodified, you should be able to toggle between them by pressing three keys simultaneously: fn, esc, and shift, all on the left side of the keyboard. I think I’ve heard that some USB hubs don’t handle NKRO keyboards properly.
1 Like

Thanks Michael for the suggestions. Appreciate your time and efforts to help me!

It is hard to do that testing, because the problems appear randomly and not always.

  1. Indirect I can state that the hub should not be a problem, because all other keyboards I use are also connected through this hub/ monitor. I rely on this solution btw, because my monitor serves as a KVM switch as well, allowing me to use all my peripheral hardware (mouse, keyboard, external soundcard, camera, scanner…) with a desktop or one of two notebooks which I connect to the monitor. No other keyboard makes problems (old USB Fujitsu keyboard and Mistel MD 770).

  2. The MD 770 keyboard also offers NKRO and does not make a problem. So if there is a problem with NKRO with the model 100 that is IMO a fault of the keyboard.

I do not even understand what “sketch” means here. I think it is the configuration file I would use for Kaleidoscope, which I do not, because I only use Chrysalis. I tried to press Fun+Esc+shift, but do not know if / where I could see if something (NKRO / 6KRO) is changed.

In the meantime I also tried to reset the keyboard (for another time, did that already a few times). This time I was able to reset the keyboard with Chrysalis, but when trying to load a previous configuration the PC froze in a way that all mouse and keyboard connection (and likely the complete USB connection) was not working any longer. I needed to kill the PC with the power button for a reboot. BTW, I experienced the same problem already twice when the model 100 was connected and not directly in use at that moment. But even when i did not use the model 100 the firmware screwed up randomly. So it appears that the keyboard is behaving strange!

I think the next sensible test is to disconnect the model 100 and see if those freezes (which appear not often, but randomly) come back. If not it is very likely that the model 100 firmware and/ or hardware is buggy. I guess that either the model 100 is buggy in general or my specific keyboard has a hardware problem (or both). I have contacted Jesse and am waiting for an answer now how to proceed. Pretty frustrating experience so far with this keyboard I must say. I did not expect that kind of problems when buying a product which was (even in an older version) on the market for several years.

The purpose of performing these kinds of tests is not to determine blame, but rather to characterize the problem so that the source can be found, with the goal of making changes to the one element of the system that we can control (the Model100 firmware). Even if your keyboard is precisely following the USB spec, it might not work properly with the hub and/or the host operating system, because lots of devices do not adhere as strictly to standards as they ought to.

Regarding switching between 6KRO and NKRO protocols: you shouldn’t be able to tell the difference unless you deliberately press and hold a whole bunch of letter keys concurrently, and even then it’s not necessarily obvious without using a key event viewer of some sort on the host. It’s possible that all of your other keyboards automatically switch to using boot protocol (6KRO) when connected through the hub, so it would be worthwhile to unplug your Model100, press that key combination just once to toggle protocols, and leave it that way for a while to see if the problem continues to occur. That could help narrow down the search space for people trying to debug the issue.

1 Like

Hello Michael,
thanks for the input. I now have connected the model 100 direct to my desktop system. We will have to wait a few days or weeks to see if there are problems again, because those appear randomly and I can not reproduce those errors by will.

Regarding switching to 6KRO I do not understand how exactly I must do that. First you wrote by pressing the three keys at the same time - I assumed on the model 100. Now you wrote I should unplug the model 100 and press that key combination. I assume I need to connect the model 100 again and then press that key combination? I tried that now and we will see what happens or not.

Whoops! Sorry about that. You are exactly correct; I left out that step. Power cycling the keyboard is intended to reset it to the default, which I believe is Report Protocol (NKRO). Otherwise, it could be difficult to tell which protocol is being used. The easiest way to verify it is by using a keyboard event viewer, and holding down seven or more letter keys concurrently. Software to do this depends on your OS, however.

I had the impression that you were experiencing problems much more often than that. Since the issue is so infrequent, I would recommend using the keyboard via the hub, but in 6KRO mode first.

Thanks Michael,
I use the model 100 currently only when practicing my new layout. So far about 17 hours. Therefore I have less chance to see problems. So depending how one looks at it the problems do occur not often (days or weeks in between), but on the other side taking into account that I use the keyboard on average 15 minutes only I have seen many problems for the relative short amount of time.

I hope I can switch in about a week to the layout completely and might then try to use the model 100 full-time – although I have not practiced the Shift-key yet, so maybe I should add that before switching. Otherwise I will be too slow.

I leave the keyboard now connected to the desktop PC (which I use for practice). As soon as I start to use it as the main keyboard I will need to connect it to the hub, because I switch computers typically twice a day.