Finally found a used Model 01... but I think it's bricked :(

Hi everyone!

Although I deeply lusting after a Model 01 during the Kickstarter campaign, life events kept me from pulling the trigger. Recently I found myself lurking around r/MechanicalKeyboards again, and saw a Model 01 for sale on r/mechmarket. This time, I didn’t think twice. It’s beside me now, in all of it’s glory :slight_smile:

There’s just one small hurdle: I think it’s bricked :frowning:


  • Right half of keyboard is non-responsive, and the LEDs have never illuminated on either half
  • Have reset eeprom and flashed to factory defaults (both standard and experimental) with both Chrysalis and command line
  • Have tried both ethernet cables and have confirmed strong connection
  • Successfully reprogrammed “x” key to “]” via Chrysalis

I’m out of ideas. I’d love to be able to bring this beauty back to life, but it’s not looking good at the moment.

Any ideas?

If you need a paper trail / receipt, the r/mechmarket seller kindly offered to provide proof of purchase that I could pass along to you. I don’t think there’s been any foul play – the owner couldn’t get used to the layout and it has been sitting in his closet for the last year or so. But the last time he had used the board, it worked properly.


  1. Board arrives in original packaging and appears to be in quite good shape (other than wobbly, squeaky keys… but I’m sure the latter issue can be resolved with some lube…)
  2. Connect halves with the longer of the two provided ethernet cables
  3. Plug USB-C → USB-A cable into my A-to-C converter and into my Macbook.
  4. The board is still dark (this didn’t seem odd to me at the time). macOS prompts me to identify the keyboard. This doesn’t work, but that’s expected.
  5. Try typing a sentence… and realize that depressing keys on the right side of the board does not produce any output on the screen. Ahhh, mannn.
  6. Launch It recognizes the Model 01. I then:
  7. Reset the eeprom memory
  8. Hold the Program button, update the firmware (standard, not “extended”) and reset to factory defaults. The board remains dark despite Chrysalis copy stating that first the Program button, and then the whole board should illuminate to signal that flashing was successful. Oh well, a “Success!” toast notification appeared in Chrysalis, so I guess it was successful.
  9. Try typing another sentence. Same result. Chrysalis seemed a little wonky … so…
  10. Find/clone the firmware repo, install the Arduino SDK, and ‘make flash’. Hold the Program button and tap Enter. “Firmware was successfully flashed!”, it says. Right side is still non-responsive and the board remains dark.
  11. Test reprogramming a right-half key via Chrysalis to verify that the board is actually in communication with my mac. This test was successful.
  12. Try the short ethernet cable. Test the connection (really making sure that cable is locked in there). It is.
  13. Log out of my primary macOS user and into a sandbox user that’s pretty much factory-default macOS. Repeat most of the steps above. No improvement.

Update: I just tried depressing the “Program” key before plugging the Model 01 into the mac and keeping it depressed until “Keyboard flashed successfully!” is displayed in the terminal.

No change, unfortunately. Both sides of keyboard are still completely dark, and it’s as if the right side is not connected at all.

I suppose I should open the enclosure in search of that physical reset button next?

Anyone? Should I email support instead?

On my model 01 the rj45-connectors between the halves are very flaky. The short cable works badly - if at all - and the longer one better but not great either. Other RJ45 produce similar results.

Thanks. I do have other Ethernet cables lying around. Perhaps I shouldn’t have assumed that one of the two should work.

I’ll try that this evening :slight_smile:

Maybe check for corrosion on the contacts, just a thought as i yesterday pulled an SD card with corroded copper contacts from my Camera that was lying on the shelve for a year :man_shrugging: Stuff happens when not stored under optimal conditions.

Unfortunately, I don’t think I’m going to be able to get the right side working.

Since the last update I’ve tried:

  1. A third ethernet cable connecting the two sides
  2. Using the physical reset button on the PCB

Does Keyboardio offer a (paid) repair service?

I think you should email support they might be able to guide you through a more detailed examination and repair process if you feel up to it, like measuring with a multimeter and maybe soldering yourself, or offer a (paid) replacement or repair service if you don’t want to do it yourself.

1 Like

Just to close this out, I got a helpful response from Jesse via email. It’s not certain that a repair attempt would be successful, and the shipping cost is substantial. So I’m going to chalk this up as an (expensive) lesson in buying used equipment.