Spurious/phantom keypresses

My Model 01 started acting up this morning: the 6, y, h, and n keys don’t respond to keypresses and occasionally dump garbage (like 6hnynn6666666666666hyn666666).

I’ve tried pretty much all the troubleshooting I could think of: I unplugged and replugged the keyboard; cleaned it with a can of compressed air; updated the firmware; and opened it to clean further with compressed air, all to no avail. Keeps doing it.

Any suggestions on what else to try would be very welcome.


Different cable? Different USB port on machine?

And if none of that works, please email help@keyboard.io!

Thanks. I tried both, and the symptoms continue. I think it’s time to write to help@

That indeed sounds like a hardware fault, most likely caused by someone being a little heavy handed at a rework station in the factory.

We’re now in touch with @herko, but if anyone else sees something like this, please drop us a line at help@keyboard.io so we can walk you through the triage process (and possibly set up a replacement.)