Flashing doesn't change keys

Hi all, first post here.

I am having trouble getting my Model01 to change layout. I’m just changing a few basic things so far, to get my feet wet.

When I first installed the firmware and flashed it, it did the update thing and it worked, using Arduino, though I had to try a bunch of times to get it to work. Now when I try to verify it says
avrdude: butterfly_recv(): programmer is not responding for awhile and then exits. I have no idea what to try, can anyone give me some next steps?

I think you’re running into something I also ran into when I started flashing custom firmware to my Atreus.

The Kaleidoscope firmware is designed to work with software such as Chrysalis by allowing Chrysalis to push key mappings into EEPROM without flashing new firmware. And this is done by using the EEPROM mappings as overrides over whatever was set in the firmware. This is great, once you get used to it - I realized I could tweak the Qukeys parameters freely with firmware updates while still using Chrysalis to easily change my keymaps. But until you know how this works, it’s…confusing.

So if you have ever used Chrysalis to update the keymaps on your board, you’ve basically uploaded a set of overrides to whatever you’re putting in your custom firmware. You’ll either need to clear your EEPROM (not sure how to do this), or continue to use Chrysalis for keymaps.

2 Likes

that was it, yes, thank you! I reinstalled Chrysalis, so I could use it to erase everything in the EEPROM, worked like a charm!

1 Like