Keyboard Suddenly Dead

Been using my keyboard for just over a year now and absolutely love it. However, it seems to have suddenly died. It was sitting on my desk at my office where it’s been for the past year, working just fine. I left for the day, and then when I came back this morning, it was just…dead. It doesn’t respond. I rebooted my computer, and that didn’t fix it. I tried plugging it into another computer and that didn’t fix it either. It’s just…dead. Anybody else have an issue with this?

Tried algernon’s suggestion from this post. - that is, holding down PROG, plugging in, and immediately flashing FW (via CLI). It did not work.

However, on my first attempt, I saw this error:

Looking for USB device with vid=1209 and pid=2301
Examining usb-FTDI_TTL232R-3V3_FT9FQWWB-if00-port0
ID_VENDOR_ID 0403 != 1209
Examining usb-Prolific_Technology_Inc._USB-Serial_Controller_D-if00-port0
ID_VENDOR_ID 067b != 1209
ERROR: I couldn’t find a USB device matching the keyboard’s USB Vendor and Device IDs
I couldn’t autodetect the keyboard’s serial port.

On subsequent attempts, I did not see this error. I just saw the normal output instructing me to hold down ‘Prog’ and release it (and when I did this of course nothing happened).

I remember that when just getting my Model01 I flashed a firmware that caused my keyboard to hang just after booting and I was unable to flash a new firmware. The Prog key in the top left is not the actual arduino program button, if you open the left or right keyboard half there is an actual button on the PCB which can be used when powering on the keyboard to put in program mode and you might be able to flash a new firmware. I can’t remember if it is the left or right half where the button is located, but it should be documented somewhere on the forum.

I founf this article, it documents the program button in the “Help, I bricked my Model01 with bad firmware!” section.

If your not able to program the keyboard when it is in program mode or not able to put it in program mode at all it is most likely a hardware related issue. I would suggest trying to confirm that the keyboard is receiving power with a multimeter or if you are uncomfortable with that send an e-mail to the support team (help@keyboard.io).

*I just though of this. You say you tried a different computer but have you also tried a different cable. It seems unlikely but cables can go bad.

Yeah, I tried a different cable. Unfortunately, that wasn’t the issue. Also opened the left enclosure and found the button. Tried plugging in with the button held down as described in the article. Tried this with both the PROG button and with the tiny button on the PCB. Also tried pressing both buttons when prompted by the make script. Nothing. :frowning:

Something not unlike this happened to me last year - I was typing, I got up for coffee, came back to my desk, touched the keyboard, and ZAP! there was a static discharge from my hand to the keyboard, and then it was dead. Only this time I did not notice any such static discharge. The only common variable I can think of is that I live in Minnesota, and both times this happened in the middle of winter when it’s super cold and dry.

1 Like

At this point, I’d strongly advise sending an email to help@keyboard.io.

1 Like

Mine died suddenly too, I sent it back and it (the left half) was FRIED. My theory was static electricity, we were all getting shocked. Someone else’s WASD Code died that month too.

1 Like

Resolution: They charged me a small fee to refurbish the board and I got it back after a week or so. Kind of a bummer, but much, much cheaper than replacing the whole thing, and mostly I’m just happy to have it working again.

Did you get a clear explanation of what exactly happened with the board, and how it was fixed?

Unfortunately not. He confirmed that it was burned out, but seemed stumped as to why it was burned out.

Hm… okay, will be sure to ground myself before touching the keyboard then.

Yeah, I’ve been doing that too just in case, although I don’t actually know if that was the problem.