Has my model 1 died on me?

Hey there, I come here desperate for options since my model 1 has seemingly just flat out died on me. I’ve been daily driving it for about 2 years now relatively problem free but in the last 3 months or so it has been acting up in some weird ways and earlier today it stopped working all together. Over these three months the keyboard has lost connection with the right half of the board which becomes completely unresponsive. The LED’s on the left half will work but the keys won’t so I’ve been disconnecting and reconnecting to get it to work again. Once the keyboard did not return to normal after reconnecting and didn’t even show up in windows device manager. I plugged it into all of the usb ports on the computer but no luck. I tried the same thing on my laptop which on the third try actually worked and after that the keyboard worked fine on both computers for about a week.Today the same problem happened, the right half died and the board altogether after i disconnected it but now i can’t get it recognized on either computer after hours of trying. Any help with diagnosing is greatly appreciated since I would hate to loose this great keyboard to a mysterious early death.

Note, I’ve checked the usb-c port which is secure, solderpoints look fine and I’m getting 5 volts to the board.

TLDR: The right half stopped working but was fixed with a power cycle (on several occations) but is now completely dead and not recognized by windows.

Hi Zkur1,

Shame your keyboard is acting up!

Over the past years, have you ever flashed a new firmware? If not, that would be my first step on an occasion the keyboard seems to be in working order.

Since you seem comfortable opening the package and doing some measurements, do you have any experience with Arduino? You could try connecting to the serial interface directly in case the board is acting dead, and see if the chips themselves still give any reaction in those cases.

In what kind of environment do you live? Any chance weather influences (condensation?) have corroded traces or contacts?

For the right hand side, did you try switching UTP cables? And what about the USB cable?

Thanks for the reply!

I was writing my reply, googled “UTP cables” realized it was the cat45 cable and figured I actually hadn’t checked the connection to the right half. I got a new cable and plugged the usb back in just to check for voltage to the right half and the board fired right up! I feel like such an idiot for not testing the cable although in my defense the left half operates independently so I didn’t even consider the other half let alone the cable that connects them to be the problem.

Thanks A TON for the quick reply, really appreciate it and can happily say I the model 1 will come with me to work tomorrow.

1 Like