Model 01 stopped working after months disconnected

I had to store my Model 01 (almost three years old) for a while. I used its travel case and kept it on a shelf, so I’m pretty sure it didn’t suffer physical damage, however, when I could finally connect it again today, it didn’t work, i.e. although the LED key flashes blue no press is registered and neither Chrisalys nor the Arduino IDE recognizes it. I tried to flash the latest version of the firmware from the command line, but after I press Enter (holding down the Prog key) it stops with the following error:

stty: /dev/cu.usbmodemCkbio01E1: Device not configured
make: *** [flash] Error 1

I can execute the built-in test mode by pressing Prog+LED+Left Fn and there’s definitely a problem: First, all the keys turn on white (should be red), I press Left Fn and they glow blue (should be green), Left Fn again and they glow green (should be blue), again and they turn red (should be white), one last time and the Left Fn key turns blue, but the rest remain red (the entire keyboard should glow like a rainbow). At this point, any key I press turns blue.

I tried different cables, but the problem remains. Is there something that I can do to get it back working?

Thanks beforehand

1 Like

I’m sorry I can’t help much with the problem itself, but the behavior of the test mode you see is correct. I see almost the same sequence of colors as you do (i.e. not the one that “should” be)—I think the docs and the code got out of sync long time ago. The only part where I see difference is that pressing Left FN while keys are red turns all the keys orange. At that point pressing any key turns it green and releasing it turns it blue. That’s meant to help with diagnostics of switches.

Did you maybe try plugging the keyboard into a different computer?

Sometimes I have issue flashing my own keyboard as well, but I don’t remember what exact message I see. Re-running make flash always helps me, though.

Drop us email at and we can talk you through some debugging. A first guess is that there’s something wrong in the path from the controller to your computer, either the USB connector on the keyboard or the cable or the host’s USB port. It’s worth trying the cable upside down, just to check.

@sidonaththanks for the explanation!

@Jesse thanks, it finally worked, same cables, same connector. I just shaked it a bit to get some debris out, but I don’t think that changed anything :sweat_smile: