Keyboard Gone Crazy; reflash even with avrdude doesn't gain response


#1

Hello,

I have a Model01 at home which I’ve been happily using for over a year.
Tonight, without warning, it went a little crazy. Apparently stopped working, I tried replugging, a different USB cable, etc.; eventually I discovered that some keys worked some of the time, but only that; and having hit some keys, keys on other connected keyboards (e.g., on a laptop that I connected the Model01 to, for testing), ceased to work. I presume bus chatter. Disconnecting allows the other keyboard keys to work.

I tried to get into test mode, but the keyboard doesn’t respond to Prog+LED+Left Fn.
I have tried reflashing the firmware; the flash apparently takes, but makes no practical difference.
I have tried using avrdude as documented here: https://community.keyboard.io/t/flashing-problem-on-ubuntu-solved/628/14; again, the command succeeds, the keyboard clearly responds (it lights up and starts rotating colours), but alas the keys do not work. And still no test mode.
I have tested different USB cables, and different hosts.
There was no obvious trigger for this: the keyboard had been working fine, it hasn’t been damaged in any way, I haven’t reprogrammed it for a year since I got it set up to my liking, it flipped from ‘good’ to ‘bad’ while I was in the room 2 feet away.

Is there anything else I can do to rescue it?


(Gergely Nagy) #2

I would advise emailing help@keyboard.io, as this sounds like a more serious and urgent matter.


#3

Thank you, fair point.

Well, it is now the next day (here in England), and I was just writing to help@ when I thought to try a few keys to give more detail… and waddya know, it has started working fine again. I needed to reflash my layout, but now it seems all okay. Weird, but much better this way.

So y’all know if this happens to you: go to bed and try it again…