Right hand board unresponsive a few seconds after connecting

As of today, the right side of my Model 01 is unresponsive. This reliably and consistently happens a few seconds after plugging the USB-C cable into the left side.

I’ve tried:

  • Reflashing my custom firmware
  • Flashing the default firmware
  • Unplugging and re-connecting the RJ45 jacks
  • Unplugging and reconnecting the USB-C cable

This video demonstrates the behavior; the num button toggles number mode on the right side as expected, but after a few seconds it stops toggling the mode. All other keys on the right side behave the same – this one was just easy to demonstrate. N.B. the right side does not lose power, as the LEDs stay lit in number mode.

Any help or suggestions for troubleshooting would be EXTREMELY welcome as I’m a bit desperate right now :slightly_frowning_face:

A couple things to check:

Does it happen if you take the wood off? (Is the connector under stress?)

Does it happen if the LEDs are off? (Is it a power draw issue)

@jesse Now it’s happening less reliably/not as soon. I was able to type out a few sentences before it started again.

I removed both wooden enclosures and thought that’d solved it, but then I started wiggling the RJ45 connectors and the right half failed again. So, I think it’s that…?

How would one go about isolating the problem, and more importantly, repairing/resolving it in this situation?

It seems very interesting/odd to me that upon initial connection of the USB-C cable, both halves function fine, but after typing for a few seconds, the right half fails – even if I’m extremely careful to not bump anything or move the rj45 cable in any way.

I should also note that once it fails, I get some REALLY strange behavior if I leave it plugged in… almost as if my OS (macOS 10.15.17) is getting constant input from the Keyboardio – things like my mouse cursor flickering, odd navigation happening in my browser, unable to type a capital J (???), etc. But, with Karabiner-Elements EventViewer open (an app that displays key presses received), nothing is shown from the Keyboardio.

Just including this detail here in case it helps diagnose the issue.

…and now I’m more inclined to think it’s a power issue. As of my last post I also had my backup keyboard plugged in. I’m now typing this on my Model 01 with the other keyboard unplugged (they were both plugged into my hub) and the Model 01 is working fine.

I don’t usually plug the backup in, but the past couple of days I have had my Atreus plugged in, so maybe it was drawing too much current?

@jesse Is there any way to tell (via some kind of diagnostic output?) if the Model 01 isn’t being supplied with enough power? I’d love to definitively nail that down as the issue.

…and now I’m baffled again. It’s happening again, both plugged into my hub (no other keyboards plugged in) and directly into my MBP (via USB-C adapter), which I’ve used in the past for many, many hours successfully.

I’m at a complete loss and pretty bummed out. Any ideas on how to proceed?

If it’s a bad solder joint, the board heating up a tiny bit during usage may be enough to cause the connection to go bad. You’d want to find someone near by with a soldering iron and maybe a multimeter to check out the solder joints on the RJ45 connectors.

1 Like

I have both of those things! Anything you can point me to in terms of tips on how to do that?

You’re looking at the row of silver pins at the back of each of the RJ45s. If you rock them, can you replicate the failed connection. If so, you may need to touch up the solder joints.

Thanks, Jesse.

This morning I figured I’d swap the RJ45 cable to eliminate that. Was working fine for about 15 minutes and then it failed again.

Seems odd to me that unplugging + re-connecting the USB-C cable would “fix” the problem (albeit very temporarily). Would that still jive with a bad solder joint? Is the theory that unplugging would allow the joint to cool off very slightly, and then plugging back in sends current through it, heating it up?

Either way, should I assume that this is definitely a hardware issue and that’s the direction to proceed in?

@jesse Actually, after disassembling this again and looking at it closely, it’s beyond my skillset to address.

I’ll email support@keyboard.io about the repair process.