Keyboard freezing occasionally due to USB port alignment issue?

Hi all! I received my Model 01 just the other day, and in general am extremely happy with it. I’m not quite back up to the speed I was at with my Ergodox, but getting there fast.

At the moment only one thing is concerning me, which is that every so often the keyboard will appear to “lock up,” at which point typing doesn’t seem to send keypresses to the computer. I’ve noticed that when this occurs, the “led” button still functions, cycling through the different colour modes, but there is a significant (~2s) delay between the keypress and the colour change.

So far, I’ve been addressing this by unplugging and replugging the USB-C connector.

Is this something other people have been experiencing? Is there a fix available?

If it’s helpful to know: I’m using the keyboard with a Macbook Pro running 10.13, and there’s an OWC Thunderbolt 3 Dock between the keyboard and the computer.

1 Like

Try a different USB cable. There has been at least one case of someone getting a bad cable that caused an issue. (And it’s the quickest thing to try and test.)

1 Like

Yes, I was noticing exactly this behavior last night. I was using the USB-C to USB-C cable that came with my Pixel, and connecting the Keyboardio directly to my MacBook. Wiggling the cable right at the keyboard’s connection made the symptoms go away, but it’s still disconcerting. Apparently there was enough of a USB connection to power the LEDs, but not enough to register keypresses?

1 Like

I’m no expert on the USB spec, but I think data and power are carried on separate wires/pins. So you could have had a good power connection but a poor data connection.

I have experienced the exact same problem (several times already). Wiggling the cable was not enough to get it back to work. I had to disconnect/reconnect the keyboard to get it to work again.

I’ve experienced this behaviour on both Windows 10 and MacOs 10.12.6.

Hi Everybody,

This isn’t an issue I’ve seen before it was reported in this thread. These are just my first thoughts on what might be going wrong.

Based on the slightly different descriptions, it may be several different issues with the same symptoms.

@nickstenning No keypresses and a ‘slow’ responses to the LED button suggest that the keyboard thinks the host has told it to go to sleep, which is…weird to say the least. Can you confirm whether you’re using the cable we sent or another one? Can you test without the OWC dock in the middle? Can you post the output of “sudo dmesg” after you catch the keyboard doing this?

@blakej For this one, the issue sounds like an interface issue between the USB cable and the USB connector. This might be caused by vertical misalignment of the connector with the plastic housing and might be something else. Does the Pixel’s cable make a good “click” connection to the keyboard? With a proper connection, you should be able to (very carefully, an inch or two over something soft) be able to hold the keyboard up by the USB cable.

@rapware - Are you seeing this with the cable we shipped or another cable? It could be a bad cable. It could be a bad connector. It could be a firmware bug. But I don’t know for sure based on your description. Next time you see the issue on OSX, can you send the output of sudo dmesg – that might tell us what’s up.

I used the cable shipped with the keyboard.

With regards to the firmware… I just created and uploaded a modified version of the firmware. So far so good (the keyboard hasn’t frozen since).

When it did freeze I also noticed the slow response to the LED button. It was in fact the only button that did respond (both on Windows and MacOs). If it happens again I’ll capture the output of “sudo dmsg”.

Thank you for your hard work to make this keyboard a reality!


The Pixel cable does click when I plug it in, but it’s definitely more of a mushier “click” than I get with the supplied cable. I was able to hold the keyboard up a couple inches using the Pixel cable, though.

That definitely sounds like your issue is a cable fit problem. Is the head on the Pixel cable “fatter” than the head on the stock cable?

One way you could test this theory would be to disassemble the left side of your keyboard and see if the Pixel cable fits better into the USB socket without the plastic in the way.

I’ve had these issues, and other where the mouse keys get locked into click mode that can’t unclick without unplugging the board. I’m suspicious of my cable first, and my OS second*. I hopefully can reformat soon to test.

*After reading about Hyper from a comment Jesse made on the Kickstarter page I tried a lot of keyboard modification software and I suspect some of the uninstalls have not been perfect; my system has been a bit weird for a while. It’s been worth it though, that game changing shortcut is something I use hundreds of times daily.

That’s almost certainly a software issue and unrelated to what’s being described here.

1 Like

My results are inconclusive.

Using a calipers, I measured the connectors on the Pixel cable and the supplied cable. The Pixel’s were about .001" larger in a few dimensions, which is probably not the issue. I tried using the calipers to help me eyeball the depth of the respective metal parts, and there the supplied cable appeared to be .006" deeper. Of course, an eyeball measurement isn’t going to be as accurate, but when I held them up side by side I could notice the difference in depth.

So that would suggest that the plastic might be getting in the way. But when I opened up the left side of the keyboard and tried plugging both cables in, they felt about the same as with the case on, and the cable’s plastic was still a couple mm away from the connector. So I’m not convinced that this is the thing.

(This isn’t a huge issue for me; I’ll keep experimenting with cables and see what else I can learn. If there’s more data I can gather to help diagnose the problem, lemme know.)

1 Like

Hi Jesse!

I am using the cable that came with my keyboard, yes. I will try without the dock in the way as soon as I can lay my hands on another USB-A to USB-C adaptor. (I have one of the MacBook Pros with only USB-C ports.)

I does appear to be caused by the cable. It just happened again after I picked up the keyboard to tighten the “stand screw”.

I’ve uploaded the output of dmesg.txt to:

That’s High Sierra? It looks very much unlike what I was expecting.

It could be a bad cable, but I may have figured out another possible cause of this, thanks to another customer.

If you unplug the USB cable from your keyboard, does the jack alignment look like this?:

Or does it look like this?:

If it looks like the latter, there’s a chance that the problem is that the wooden enclosure was milled imprecisely and is pushing on the plastic baseplate, causing the USB jack to be misaligned with the plastic that protects it. This could either be stressing the cable or stressing the connector, causing a disconnect.

If this is the problem you’re running into, it’s easy to test – just loosen the screws on the bottom of the left half of the keyboard a bit and the jack should realign. You may be able to get away with only loosening the back three screws or you might have to loosen all of them.

If that realigns the jack, try running with it for a while and see if you continue to see disconnects.

If this fixes things, there are a couple more permanent solutions. We need to test them before giving you actual advice, but the three we’ve thought of so far are:

  • sand the wooden enclosure near the USB jack just a bit to relieve the pressure on the plastic
  • sand the plastic of the USB jack protector to relieve the pressure on the plastic
  • Insert plastic washers between the baseplate screws and the enclosure.

That last one is, by far, the least invasive solution. It’s also the only one that I’m not sure will work. I’m going to need to source a variety of plastic washers to see which ones fit correctly.

If the problem you’re seeing is caused by this issue and the washer solution appears to work correctly without causing other issues, we’d be happy to tell you which washers seem to work best and to send some out to you to test.

1 Like

It looks like the second image. It indeed appears to be misaligned. I’ve loosened the base plate a bit and the jack is now aligned properly. I’ll sand the enclosure next weekend and I’ll let you know the results.

ps. It really is Sierra (10.12.6)


If you do, you may end up wanting to re-seal the sanded bit with polyurethane, just to make sure you don’t run into moisture issues.

Either way, I appreciate the confirmation and look forward to the report.

Huh. I must be out of touch. I thought dmesg on OSX looked a little different than that.

1 Like

Is there another thread about this jack alignment issue, or another way to follow progress? I haven’t have any issues with disconnects in the few hours I’ve had my Keyboardio, but the pictures made me curious, and my USB jack also looks like the second picture. When I unscrew the three screws at the back, I’m able to see the whole USB jack, but as soon as the screws are back in, it’s partly covered. I hope it’s not causing extra stress…

There is not currently another thread. In most cases, we’re seeing the alignment to not be so far off as to be stressing the jacks. Once we have a better sense of what’s up and what the correct mitigation is, we’ll give folks a heads up. If we end up that it’s likely to cause damage, we’ll be proactive about reaching out to anyone affected.

1 Like

The cutout is a little bigger than the jack itself, so the jack not being centered isn’t necessarily catastrophic. You might consider not re-overtightening those rear screws when you reassemble.