Keyboard not detected (anymore) on Linux

Hey all,

Just received my Model 01 this morning. I quickly opened the package and connected the keyboard: it worked great, the LEDs worked and I could type on it normally. Cool! I put the keyboard back in its box.

Few hours later, I try to use it again but now it doesn’t work at all. No LED working when I plug it. If I type anything, nothing shows up on screen.

Here are a few things to know:

  1. I’m on linux (arch). If I type ‘lsusb’, the keyboard is not on the list.
  2. My motherboard is getting quite old (socket intel 775) and only has USB 2.0 ports. I don’t know anything about USB, could there be a compatibility issue here?
  3. Depending on the port I put the USB cable of the model 01 in, other devices stop working. One port, the mouse stops working, another one it’s my other keyboard, another one everything works (except the model 01)… This is the first time something like this happens on this computer.
  4. I tried both RJ45 cables, I tried the given USB-C cable and another one I already had for a phone, it doesn’t seem to change anything.

I’ll be able later this evening to try the keyboard on other computers with linux and windows. Meanwhile, any idea to help is appreciated :slight_smile: Thanks

I haven’t had this problem with my Model01 (yet!) but it is a recurring problem with my kinesis. I have a cheapo USB switcher that I use as a poor man’s KM switch, and when I reconnect to my dell+debian laptop I find there are random delays before the OS recognises the keyboard. Sometimes this delay is effectively infinite, in which case plugging into a different USB port seems to help.

I suspect this is a firmware issue in the laptop’s usb system - I haven’t noticed this problem on my desktop, which runs the same version of linux, or on my mac.


@Leimi - I’m so sorry! That’s definitely not the experience we want you to have. We’ll make this right, one way or another.

Based on the fact that lsusb isn’t showing anything, I’m 99.99% certain it’s a hardware issue. Could you please email us at and we can step through a bit of debugging, figure out what’s wrong and set you up with a repair or replacement?

Thanks for your input, I’ll try again with different ports on different computers.

Oh well, that doesn’t sound great huh. I’m the Emmanuel P. that had trouble with shipping btw. Pretty unlucky with this keyboard for now but I’m sure it will end well haha.

Anyway, I actually managed to forget the keyboard at my workplace and tomorrow is a public holiday here in France (told you, no luck).

I’ll continue the investigation and email you in two days I guess!

Oh gosh! I’m so, so sorry. A couple things to check:

We’ve now had 3 reports of bad cables.

  • Try this cable, plugged in upside down.
  • Try a different USB C cable.

If either of those fixes the issue, we’ll just get you a new cable. If neither does, we’ll just get you another keyboard.

Either way, enjoy the holiday tomorrow!