Model 01 does not work

I know it is counterproductive to say it does not work, but it is the only way I can describe this problem. I picked up the keyboard today after some time of not using it and plugged it in to my laptop and… It does not work, nothing happens. I try to type something (obviously not using it now), and nothing happens. I change USB port, checking connectors, but still the same. In the past I had some problems with the RJ5 connectors between the keyboard parts, but even so, it should work? Then I downloaded Arduino, setting it up, only to find “Ports” are grayed out. So I cannot flash any firmware to the Keyboard (?). I am on Windows 10, if that matters.

So yeah, I have done everything I can think of. The USB cable works, I can connect my phone, and USB ports on the computer works. The keyboard worked a few months ago but after time of not using it, I cannot get it work again.
Ideas? How can I proceed?

Can you elaborate though

  • try another RJ45 cable
  • if you don’t have another, try using it as your LAN cable (connecting your laptop to router) and see if it works. Do you get an an internet connection using the cable?
  • try using the keyboard on another computer