macOS: stty: /dev/cu.usbmodemCkbio011: Device not configured

I’ve tried to change key layout. Displayed the following error.

  • Mac 10.12.6
  • Arduino IDE 1.8.5
$ pwd
$ ls
Model01-Firmware hardware
$ cd Model01-Firmware
$ make flash
BOARD_HARDWARE_PATH="/Users/akihito1/Documents/Arduino//hardware" /Users/akihito1/Documents/Arduino//hardware/keyboardio/avr/libraries/Kaleidoscope/bin//kaleidoscope-builder flash
Building output/Model01-Firmware/Model01-Firmware (0.0.0-gv1.13-55-g8ab1) ...
Press ENTER when ready...

stty: /dev/cu.usbmodemCkbio011: Device not configured
make: *** [flash] Error 1
  • the keyboard is connected
  • LED works, key-input works

Device not configured:confused:

Any suggestions for how to debug?

Thank you.

I think the standard first thing to check is that the PROG button is being held down while make flash is running?

The PROG button is being held down, I received the error message :cry:

After that, I changed key layout successfuly by using Arduino IDE instead of CLI.

Thank you for your help. :blush:

1 Like

I just got a swap of the circuitry of the left hand of my keyboard, and now I’m seeing this as well. (My error message is has “kbio01”, rather than “kbio011”, but otherwise it’s identical.) I’ve tried holding down PROG while pressing Enter; holding down PROG before typing “make flash” and keeping it held until after the “Press ENTER” prompt; unplugging the keyboard, starting the “make flash”, then holding down PROG while plugging it in and pressing ENTER at the prompt. All give the same failure.

I think I saw this once or twice before the circuitry swap, but eventually I did something slightly different (sadly I don’t remember what) and it worked. But now I’m getting no luck.

I haven’t tried the IDE yet; even if that does work, it seems like the CLI issue should be understood better.

Can someone open a ticket on I have some ideas for how to fix the code.

issue here:

1 Like