Model 100 -- How the heck do I get MacOS to recognize it?

Okay, so I think I have navigated past the firmware corruption issue by reflashing: the keyboard is now recognized by Chrysalis. But how do I make it past the MacOS Keyboard Setup Assistant?

It tells me the keyboard is not recognized and won’t function until I press certain key combinations, as usual. But then it asks me to “press the key to the right of the Shift key (on the left hand side).”

There IS no key to right of the Shiftt key. I tried hitting the Fun key, but it doesn’t recognize it.

I tried getting to the next setup screen by pressing Z (which is typically to the right of the Shift key). But then it prompted me to “press the key to the left of the Shift key”. This is the Cmd key, but again the Setup Assistant doesn’t recognize it.

Any workarounds? Getting frustrated. Thanks.

I experienced the same thing and found that typing “z” for the first question, and “/“ to the next question, worked just fine. I also read somewhere that you can just cancel out of that window and the keyboard should work. But I used the z, / responses and it worked well.

Thank you. I tried that and it seems to work.