NumPad colouring problems and turning it off


(Shriramana Sharma) #1

I want to turn off the colouring effect caused by the NumPad plugin. I thought that merely placing the NumPad plugin before the LED effects in the KALEIDOSCOPE_INIT_PLUGINS would be sufficient but I find that this does not work.

  1. If the current LED effect is a solid colour, it gets overpainted by the NumPad colours.
  2. If it is Rainbow or Breathe, the rest of the keys go black.

Is it worth to create a PR to add a boolean toggle for the NumPad plugin to avoid doing the colouring? The plugin is still needed to handle the numlock state so I can’t avoid including it in toto!


(Gergely Nagy) #2

Wouldn’t a macro that toggles NumLock and the layer work?


(Shriramana Sharma) #3

Works for ordinary switching to and from lock layer numpad but doesn’t work with a Qukey based temporary shift to layer numpad. Possibly this is because a macro especially one containing numlock isn’t a modifier.


(Shriramana Sharma) #4

Also consider the case of the person who wants to use ColorMap or such to highlight the numpad layer keys with more detail, such as a different color to the operators.

And I have some editing shortcuts added to that layer as they are obscured by the overlay otherwise, and they aren’t highlighted since their flags aren’t off as I asked in the other thread.

Adding all this customizability to the existing numpad plugin would lead to the point where all this LED-related functionality really belongs in a separate LEDEffect-NumPad plugin…


(Shriramana Sharma) #5

I tried a workaround by bracketing all the number keys in that layer by LSHIFT so I may not need to use KeypadNumlock either explicitly in a macro or indirectly via the plugin, but:

  1. that’s a kludge
  2. it is behaving erratically and I don’t have time to debug that.

The easiest thing to do is to use the plugin, but turn off its LED effect.


(Shriramana Sharma) #6