Oneshot is broken

It seems that oneshot plugin is broken, I tried many times and even compiling the example directly from the repository, it just won’t work.

Any advice?

Is only OneShot not working or do no changes apply at all - like changing a regular key? Does the compilation fail or does the flashing not work? Did you use Chrysalis to modify your keymap before and are now flashing a custom sketch?

Otherwise I can only say that OneShot works, unless there have been very recent breaking changes.So we would need more information of what you are trying to do and what exactly doesn’t work.

@alfalfasprossen sorry for not being detailed enough

I can compile and flash fine.

When trying to use the shift key for example it either does not work or start inserting spaces until I press another key.

I have tried to compile the sample provided in the repository https://github.com/keyboardio/Kaleidoscope/blob/master/examples/Keystrokes/OneShot/OneShot.ino same results.

Wondering do anyone has a guide how to debug this?

@jesse any ideas, what am I doing wrong?

embarassed I’ve never actually used OneShot.

1 Like

I’m not an expert on debugging these things, I can only guess from what issues I have come across or read in these forums before.

  • Is there a eeprom-keymap (from using Chrysalis) stored that may shadow the one in your sketch? I guess this is unlikely as you said that flashing works fine, so I guess that means that changes to the layout actually apply? (Like moving a regular key to a different position).

  • Is Arduino using the latest Keyboardio modules? I’m not sure about updating the ones provided through the Arduino IDE, but I know some people were having issues with conflicting versions between what a sketch uses and what the released modules provided. Also if you cloned the git repositories, are you sure that Arduino is actually using those? (If you followed the setup in the wiki you should be fine here.)

  • Same as above, but assuming you cloned all the respective git repositories - did you make sure to checkout the latest versions and the submodules as well? git pull --recurse-submodules would be one way to take care of that.

  • Are you using third party modules in ~/Documents/Arduino/libraries that may cause issues here? I guess if you compile the OneShot example sketch, there shouldn’t be anything used that might cause side effects like these though, so this is also unlikely.

Most times when people are facing problems related to version differences, the compilation fails though, so these also sound unlikely to be your problem.

:thinking:

at least you are honest about it :stuck_out_tongue:

Thanks for your suggestions

  • I don’t use the eeprom-keymap and Chrysalis

  • I did use both my linux and mac to compile and flash. The mac environment was setup from scratch using the instructions from the wiki

  • Same here, I did clone Kajnediscope and it ran all the submodules clonin

  • I don’t use anything else in the Arduino workspace.

I would really like to rule out some issues with my environment. Would you mind trying to compile the sample from the repository and just double check if it works for you?

You mean the OneShot.ino file? I flashed that to my Model 01 and it works as it should. I’m using the Arduino IDE on Windows though, but I don’t think that makes a difference.

Is only shift a problem with OneShot? What about the other modifiers, or moving shift to a different key? I mean as you already flashed from different setups it might be some hardware-related issue.

OK, I worked a bit more on this. I have noticed that oneshot was working fine when I have only the left halve connected. As soon as I connect the right halve the keyboard start sending space characters.

I opened the right halve and tested the resistance (ohm) on the switch used for the space bar. The tester is showing 1 ohm despite the switch not being pressed :cry:

@alfalfasprossen thanks for taking the time to test out the OneShot sketch.

@jesse I have one of the keyboard that had the issue with the chatter keys, I have been putting isopropyl alcohol every 2 months or when issues reappeared. Wondering if it broke the switch. :thinking: . Do you have any method for me to open the switch or replace it?

Typing this on my model01. :tada:

I took the switch apart couple of times and it seems to work better now :crossed_fingers:

I should probably buy a couple of switches just in case it dies on me for good…

@jesse what the exact reference of the switch I should buy? I am using a quiet type. :bow:

The switches you’re looking for are Matias KS101Q. If you’re based in the US, the easiest way to get them is to drop mail to help@keyboard.io.

Thanks Jesse sadly, I am in Japan so probably better if I try to source the switches from local vendor if I can.

In Japan, the first place I’d try is Yushakobo.jp. if they don’t have them, they will know who does.

1 Like

@jesse I tried contact them sadly I got “we don’t know answer” looking over the web most of the vendors are in Europe or US. How much is the shipping from US?

Asking around, it sounds like kprepublic in China would be your cheapest bet for KS101Q switches shipped to Japan