Possible bug: scrolling on mouse movement

I just had something weird happen.

I don’t know what exactly I did, but I suddenly noticed that I couldn’t focus any window other than my terminal by pointing at it with the (real) mouse. (I use a window manager with “focus follows mouse”.) First time this has ever happened.

I then also noticed that if I moved the mouse pointer up, the terminal window would start scrolling its contents up, and the higher the pointer was, the faster it would scroll. If I moved the pointer down, it would scroll down.

This reminds me of “scroll wheel emulation” which I’ve seen before on laptops.

Since I’d never seen anything like this before on my desktop machine, I unplugged and replugged my Model 01, and the problem immediately disappeared.

I wish I could give more information.

Did you maybe hit Fn+V? That would send the middle mouse button command to the machine with the default layout.

My middle mouse is mapped to fn-a and it’s possible I pressed it by accident. But middle mouse button does not act as “scroll wheel emulation” on my machine and, further, I actually thought of that and tried pressing the (real) middle mouse button while in the broken state. It pasted the selection as it should, and things remained broken. I did not think to try the Model 01’s middle mouse mapping.

I did use the mouse movement keys a little and they did not help. I may not have tried all four.

I think the question is probably whether mouse wheel emulation is something which can be triggered by the M01. If so, I’m guessing this happened somehow and got stuck in the “on” state.

We don’t have any wheel actions in the core. There is an open ticket about mouse clicks sometimes be interpreted as click-and-holds.

Hmm. While it could be related, I’d find it weird, since holding middle mouse button (whether real or the M01’s one) and moving the mouse around doesn’t cause the scrolling behaviour for me. I just get the selection pasted once I let go.

I have found sometimes that hitting a mouse click in the fn layer and releasing fn first results in no button-up event being sent.


OK, I can reproduce that.

If I hold fn, then hold a (my middle click button), then release fn, then release a, the focused window gets locked as I described in my original post. I haven’t yet, however, been able to reproduce the scroll wheel emulation effect.

I can clear the issue by sending another middle mouse button via the keyboard (releasing a before fn).

1 Like

It really does sound to me as if you’ve triggered wheel emulation; we just need to work out what particular trigger your OS saw. ChordMiddle perhaps?