Same firmware yields different results when switching hardware

Howdy folks!! I was wondering if anyone would be willing to lend some assistance with an issue I recently discovered.

I have two Model01 keyboards and I’m trying to tweak the firmware to add key bindings on the function layer for mouse scroll wheel control. I’m choosing to bind keys as follows, assuming a standard QWERTY layout:

  • E --> scroll up (Key_mouseScrollUp)
  • C --> scroll down (Key_mouseScrollDn)
  • Left Control --> scroll left (Key_mouseScrollL)
  • Left Shift --> scroll right (Key_mouseScrollR)

I flashed the firmware to both keyboards but they behave differently; one of them works as expected and the other behaves as though the function key was never pressed, and I just get ‘E’ and ‘C’ keypresses.

I’d be most grateful for some assistance with debugging advice, and diagnosis. On the ‘broken’ keyboard I’ve attempted re-flashing several times to no avail, and I’ve tried activating the function layer with both keys. I’ve confirmed that the function keys are indeed working and shifting to the correct layer, as I can use the standard mouse keys like ‘W’ and ‘S’.

I’m using Model01 Firmware at commit f4ff736 with Kaleidoscope at commit c57c69f4.

Thanks in advance for any assistance.

EDIT: added clarity around versions.

The usual culprit in cases where keymap changes in firmware seem to not take is an existing Chrysalis keymap, which overrides the built-in keymap. Have you tried wiping the EEPROM via the Chrysalis Preferences?

Hi Michael,

That’s done the trick perfectly, thank you so much for the help! I think I had used Chrysalis with one of the keyboards and not the other, hence the difference.

Cheers again.