Chrysalis firmware, ctrl+fn+keypress doesn't get sent

Hi There! I’ve been a long time user of a customized Model01 firmware, with my own plugins and layout. Still now that we have Chrysalis in a usable state, and being tired of having to recompile and reflash for simple layout changes, I figured I’d download Chrysalis 0.6.2, flash the included firmware (default variant), and customize the layout with the much more convenient graphical editor.

So far so good, but I currently have this situation:

Layer 0: Fn key is “ShiftTo 2”
Layer 2: the “esc” keycap is remapped to “End”

Now, if I press Fn + LCtrl + End, I don’t get any keypress on my computer (linux, using xev to test, same with text editors). Is this a bug, or what am I supposed to do here?

Here’s my layout for layer 0 and layer 2:

Note that I also have keys for “C+Home” and “C+End” in Layer 2, those work as expected, so I can use those instead. I’m just thinking it should also work when pressing Fn + LCtrl + Home/End/any other key in layer 2.

I have the same problem. Very different layout and not using Chrysalis (yet) and when I press the same keys (physical positions. not the same funcions) my keyboard is “ejected” and I hear the sound of an usb device being disconnected. If I press them again I hear ir being re-connected.

Don’t really know the problem but this is not what I configured it to do.

In the default firmware, Left Fn + Esc + Shift (aka R3C6 + R2C6 + R3C7) are mapped to a magic combo that switches from NKRO to 6KRO mode. Is it possible, that this is in play here?

Yes, it definitely sounds like, I didn’t think about it (didn’t know)!

So, how do I disable the magic combo or move it to something else, do I have to go back to compiling my own firmware? If so, can you point me to where to find the exact configuration used by Chrysalis’ default, no bells and whistles firmware, so I can start from there to customize it?

Yes, you need to compile your own firmware to disable it at the moment.

Chrysalis uses the Model01-Firmware repo for the no bells & whistles firmware, so you should start there. To disable the combo, simply remove line 424-427. You can also fully disable the MagicCombo plugin (but then toggling between NKRO and 6KRO gets disabled too), by removing it from the list of plugins in KALEIDOSCOPE_INIT_PLUGINS().