Shift as secondary action on home row not working [solved]

Using Chrysalis, I’ve set Shift as a secondary action under F and J, but they don’t work. I also have set Command as secondary action under D and K, and that works perfect.

Is there something I’m doing wrong? I already tested with Space Cadet enabled/disabled, but no such luck. What else can I do?

Thanks in advance!

Not sure what changed, but for some reason Shift is working now. So, consider this issue to be solved.