Stuck key sticks regardless of physical key

I thought I’d run into the stuck/repeating key issue, but then it got a bit weird…

  1. Yesterday my backspace key started behaving weirdly. It would respond when pressed, but it was unpredictable whether it would remove 1 character, a couple, or keep going for several seconds. And it would trigger randomly even if I hadn’t pressed it for a while.

  2. I tried the “Simplest solution” from Jesse’s guide What to do if your keyboard seems to duplicate keystrokes or a key stops working. The key stopped responding entirely, and has not worked since. The random triggering occurred a few more times, but that also stopped after a bit and has not happened again.

  3. I tried the “Alcohol cleaning” solution. No change - still doesn’t respond.

  4. Busted key, right? I gave up, with the intention of emailing support. In the meantime I disabled that key via Chrysalis and bound backspace to another key, only to discover that ANY physical key, bound to backspace, repeats until another key is pressed. (specifically, I’ve tried the actual “any” key, and the “cmd” key)

  5. I flashed the “Chrysalis 0.7.9+282 default” firmware. Stalker LED mode indicated that the Backspace key is permanently pressed. However the problem of other physical keys repeating when bound to Backspace has disappeared.

Thinking about it, the repeating-key issue is a problem I’ve had before with the left shift key. Also solved by reflashing. :man_shrugging:

Any thoughts or suggestions? I’m emailing help@keyboard.io now.

The first thing I would try is updating the firmware. Version 0.7.9 appears to be almost a year old now.

Have you tried putting the keyboard into test mode to see how the physical keys respond? That would help to narrow the issue down.

Thanks for the reminder! That was what led me to re-flash in the first place (I had apparently removed test mode in my custom firmware).
The result of test mode is… all keys work normally. WTF?

I tried to re-bind the backspace key for further testing, but now Chrysalis refuses to connect OR flash so I have a bit of manual tinkering to do.

Excellent point, thanks. I could have sworn Chrysalis auto-updated but it seems I was wrong.
I updated but - as above - it now refuses to connect OR flash. It is detecting the keyboard at least.

I’m not surprised. From your description, it’s pretty much got to be a software problem.

It turned out that a reboot fixed the connection/flashing issue.
I re-bound the physical key back to backspace, and… it worked fine. Literally nothing has changed (except unbind/rebind, and the Chrysalis version)

Problem solved, I guess? I’m wary that it’s a sign on the key being on its way out.