Keyboardio broken this morning

I was working away in Intellij and began to get very weird corrupted keyboard behaviour.

First thing I did was try another keyboard - no problem there, so not mac osx’s fault. Then I wiped the keyboardio firmware using the latest chrysalis, 0.75 (default, then experimental, which i was using in a previous version, then default again). I chose “reset to factory defaults when flashing”. Also tried another ethernet cable for the keyboardio.

I get the following reproducible behaviour after all of this: hit space twice in rapid succession (like a double click), and it enters auto-repeat mode, which can be stopped by pressing escape. I have reset the keyboard as far as I know, and have not added that functionality anywhere. What is going on?

P.S. I have just noticed Jesse’s post about keyboard chatter - the problem I have occurs on any key mapped to space, so seems not a mechanical problem.
That said, I think I also have the mechanical chatter problem now - on the thumb space key which is the most used - sometimes it doesn’t activate.

More information: I’ve now discovered something very weird, perhaps a hybrid “hardware-software” problem situation. The behaviour of toggling auto-repeat behavioiur occurs only with the thumb space key mapped, as it is by default, to space. That key seems to have the mechanical problem described by Jesse in the Announcement post. I mapped another key to space, though, and my claim above about it not being mechanical was based on the observation that that other key exhibited same problem behaviour. However, I note that occured when both that and a mal-functioning key are mapped to space - keycodes they emit may seem to interact. Thus, if I remove the mapping to space on the malfunctioning key, the other, normally working, key, mapped to space on its own now does not exhibit the double click repeat behaviour I described. Thus, maybe this problem is all mechanical, but with complex manifestation as described.

Sorry for the speling mistakes, I can barely type on my old mac keyboard.

Update: I tried inverting the keyboard and pressing 30 times as suggested, now the key works even less frequently.

Update 2: While I thought I had got back to a temporary working situation, by mapping the broken key to transparent, (it was interfering otherwise, stuck on most of the time), I now have another problem. I’m getting the double click behaviour. Is there a feature in current firmware where if a key is tapped quickly, like a double tap, that it stays on in repeat mode even when the key is not held? This auto-repeat can be cancelled by me either hitting escape or backspace. This seems intermittent too, so I don’t know if there is still a mechanical problem (or a second mechanical problem) interfering with this also.

Update 3: I noticed the same auto-repeat was happening without even a double tap. It occurs on layer shift 2 with space, which i have mapped to enter. it was not occuring with the dedicated single enter key. Then, I removed the usb cable from keyboardio for a few seconds, replaced it, and the phantom sticking went away.

P.S. I love my keyboardio, I tried a UHK before, but now cannot imagine going back to a non-orthonormal keyboard!