Stupid question: CAPS LOCK


#1

Somehow I got into caps lock and couldn’t get out. It isn’t on the cheat sheet I have.
I was typing fast, so who knows which/ how many keys I pressed at once. :slight_smile:
What is the key combo?

thanks, greg


(JP) #2

I don’t think there’s a default caps lock on the qwerty layout. I’d check your config. Do you have one shot mods or stickies on? I know if I double tap shift, it becomes persistent. Do your numbers work or are they meta?

Worse comes to worse, reboot.


#3

The weird thing is that my layout is completely unmodified.

I rebooted.

Thanks, greg


(JP) #4

Type fast again, see if you can replicate.


(Gergely Nagy) #5

Are you, by any chance, using keys on the Fn layer, like Fn-U or Fn-I ({ and }, respectively)? I seem to recall there being a bug that might result in Shift getting stuck. If I remember correctly, we fixed it since, so updating to the latest firmware should help with that, if you’re hitting this bug. (Again, if I remember correctly - I might be remembering wrong.)

If it happens again, check if numbers appear shifted too! If that’s the case, then you have a stuck Shift and not a CapsLock, as that only affects alphas. In this case, if you don’t want to upgrade the firmware (which can be a scary process at first), disconnecting and reconnecting the keyboard should help. (AKA, rebooting the keyboard, not necessarily the whole computer)


#6

I do use keys on the Fn layer. I’ll keep my eyes out for this bug (if it is the bug, and if that bug exists. :slight_smile: )

Thanks all for your help.
greg


(Daniel) #7

@gergyor Did you by any chance hit capslock by mistake on another keyboard (e.g. on the laptop’s keyboard, if this is a laptop, or on your old but still connected keyboard)? I know I had that problem before changing the layout of my Model01 to have capslock itself…


#8

Good thought, but no, this changed right in the middle of typing.

greg


(flussence) #9

If you’re using a recent firmware, capslock is on Fn+LED.


(David Glasser) #10

Yep, added at https://github.com/keyboardio/Model01-Firmware/commit/a5b86bea5

I had the opposite question, but I figured it out while composing this: I updated my firmware to include that commit but caps lock didn’t work. I had to go to my mac System Preferences -> Keyboard -> Modifier Keys and change Caps Lock to be Caps Lock (which I want to be different from my laptop keyboard, which it does support).

Now, it would be nice if Kaleidoscope-LED-ActiveModColor supported this too (or maybe it would be a nice default)…


(David Glasser) #11

Aha, https://github.com/keyboardio/Kaleidoscope-LED-ActiveModColor/issues/10