Fn key behaving as if stuck, and other sporadic weirdness

Hello everyone, this is my first post in this forum. I’ve been a very happy keyboardio user for a few years now. I never used a different firmware than what the keyboard came with. However, after years of flawless operation, in the last few days I’ve seen some strange things.

Sometimes the keyboard suddenly acts as if the fn key is stuck. I noticed an issue from 3 years ago saying the same thing, but it seems nobody has seen this happen since then: https://github.com/keyboardio/Kaleidoscope/issues/266

I usually seem to be able to get it out of this state by randomly pressing keys while holding the right fn key. It’s totally unpredictable so far when this will happen, or how to get out of it.

Another strange thing: today after freshly rebooting my computer, my “caps lock” key was on! My login screen said so, and I couldn’t type my correct password.

This morning I tried flashing the latest Model01-Firmware, but it didn’t seem to have any effect.

I tried the keyboard with a different computer and found the same issue. I also tried a brand new USB cable – same issue.

The only other thing to mention is that I have sometimes had another keyboard connected, because it shares a USB dongle with a mouse that I use. However, I have seen this problem plenty of times even when the other keyboard is not connected, i.e. even when I freshly boot my computer with only the keyboardio connected.

The facts I’m sharing may not be very helpful for diagnosis, so I don’t necessarily expect anyone to know what’s wrong, but I want to at least record this experience and see if anyone else has ever seen this with the latest firmware.

What is your gut reaction: is this a software, hardware, or mechanical issue?

The keyboard has been in “stuck in fn mode” for over a day now. Small update: I did take off the Fn keycaps and jiggle the switch a little, which knocked it into normal mode for a few seconds, but then it got into stuck mode again. It might have been a placebo effect, I could not reproduce it, it is just stuck again.

Does it work for any period of time? If not, it sounds a little like my space key which went haywire being constantly pressed then unresponsive. That was a hardware problem with the switch. I would email support@keyboard.io. They are very responsive.

It would work for some time, the problem sporadically moving in and out, but now, it seems to have permanently set in. I will email support, thanks for the suggestion!

Just want to update on my situation:

I emailed support, and Jesse got right back to me saying that indeed it most likely was a problem with the switch. They sent me some replacements, which I installed, and sure enough, it fixed the problem. I am now typing this on my Model 01! Thanks Jesse & team for the help!