Keys stuck for no apparent reason

question

#1

Recently my keyboardio became pretty much unusable. When plugged in it presses keys from the ‘3edc’ collumn. Mostly the 3.
I attatched photos where it is in the led-mode that shows what buttons are pressed.

This is a loud click one, I got it about summer last year, I have started to use it in the past month more actively, since I had no desk until then (student life :D)

I have no experience with debugging hardware or disassembling mechanical keyboards, this is what I figured so far:

-The keys do not seem to be stuck. I tried pressing them, spamming them, pulling and wiggling them gently.
-It is not an usb cable issue. Plugging the usb into different slots on my pc and replugging it on the keyboard end, changing the cable did not resolve it.
-I’ve read a long time ago that there was an issue with too much grease, that would shorten some contacts, but as far as I remember it was only an issue with the quiet click keyboards.

I have not tried removing the keycaps or opening the keyboard up yet.
If anybody has a solution, any leads or tips, I’d be thankful for your help.


(Gergely Nagy) #2

I’d suggest going into test mode first (see here for how), and see if that marks any keys as chattery. Then, e-mail help@keyboard.io (regardless of the results of entering test mode, but with the information included), and they’ll walk you through the options, and help figure out how to best fix the problem.