Key not working (simultaneously permanently on and not on at all)

I’ve used my keyboard for over two years now (awaiting my upcoming Atreus, too!). Today my os started acting like I was permanently holding down a key (and issuing a key repeat beep). This eventually stopped, but then I realized I can no longer press the ‘a’ key (I’m currently typing on a different keyboard). I can’t tell for sure whether the key is permanently on or off now (The keyboard settings seem to indicate it is permantly on, but my OS is acting like it’s permanently off - perhaps MacOS has some failsafe where if you press the same key too many times it auto-ignores them?).

If I switch to the AlphaSquareEffect LED mode (which displays the last pressed character using all the leds to draw the character), it now always displays ‘A’. Switching to StalkerEffect (lighting up recently pressed keys) shows my ‘A’ key as permanently lit up.

I’ve reflashed my firmware, tried upgrading to the latest release, wiped to factory settings, restarted the computer, unplugged/plugged in the laptop, taken off the keycap to see if anything’s stuck, etc. to no avail.

Lastly, I cannot enter the hardware test mode either (looking at the code you have to press PROG, LED, and FN at the same time (while pressing no other keys). I believe I can’t enter the hardware test mode because it’s also seeing the ‘A’ key as being pressed.

Has anybody else experienced this? Any suggestions very much appreciated.

This sounds like something worth opening a ticket with Keyboardio ( They have some steps they’ve been able to walk a number of us through to sort out issues with keys. Good luck, hope it’s something simple! :slight_smile:

1 Like

Have you tried to clean or open the keyswitch to see what’s happen inthere ?

See @jesse post about how to clean a switch : maybe just a dust in the contact part :game_die:

If it don’t work, you can still open the switch to clean the inside : be aware that is not a difficult thing, but it has to be done carefully, to avoid damaging the key-switch and having to resold an other one (which is an other level of maintenance !). You can try the method used to replace the inside mechanism, and remount the original one (after a good cleaning) :muscle:

1 Like

I have a couple chatty keys, and this feels more like “burnt out component”. I’ll try opening up the switch and taking a peek inside. If that doesn’t work I’ll contact support per @bitzbyte363’s suggestion. I’m hoping that the worst case is soldering on a new key switch.

@azound That sounds a lot like a mechanical failure. You should absolutely drop us email at so we can get you a care package of replacement switches to solder in.

Thanks, Jesse - I’ll send that mail

Jesse helped me out last time by helping replace the A key on my keyboard. I’m now seeing this again on my I key. It was showing chatter, so I used the techniques suggested in this thread: What to do if your keyboard seems to duplicate keystrokes or a key stops working

After performing the alcohol steps, when I replugged in my keyboard the I key was permanently in a pressed state. I.e. pushing the key didn’t do anything and switching to the StalkerEffect shows the I key as permanently lit up. If I plug it into my computer it will usually not register any I presses, though sometimes it just registers permanent I presses (infinite key repeat).

The solution last time was to replace the A keyswitch, so I’d like to do the same with my I keyswitch.

A few questions before I do:

  1. Are there any other diagnostics I can do before resorting to the soldering iron?
  2. Does anyone know a good place to purchase a replacement Matias Quiet Click keyswitch (I only need one - or a few to have spares, but not a whole bunch)? @jesse if you have any in-stock could I purchase a few off you directly (for local pickup)?

Thanks in advance!

This apparent inconsistency may be due to the OS suppressing non-modifier keycodes that are held on when another non-modifier toggles on.