Unable to type numbers into iterm

I am completely unable to use iterm2 on my new mac (I’ve always used linux before now, so not saying this is a new issue), since when I try to type numbers into the terminal I get this exact behaviour. Numbers work completely fine everywhere else (from what I can tell).

I have tried many things, most notably this recommendation, fiddling with iterm’s profile directly, and trying to remap the numpad keys in karibiner (see image to see what I mean). No matter what I do I can’t prevent modifier that comes before numbers from making the terminal unusable.

(also, the default terminal also has this problem and sometimes just doen’t print the number keys)

Here is my layout: https://github.com/JasoonS/Model01-Firmware I updated from the latest code about 1 month ago (the only changes are the layers, and I modified the top row to be more like programmers dvorak).

Any tips would be appreciated, it is a mac given to me by my company, and as a software engineer I’m really disabled by having mulfunctioning number keys in the terminal.

Do you have this problem with the number row keys, the (simulated) numeric keypad, or both? The standard Model01-Firmware sketch changed the NUMPAD layer keys from Key_Keypad1 to Key_1 (et al), I believe for exactly this reason.

1 Like

Hi @merlin, thanks! Yes changing to Key_1 etc worked perfectly. :pray:

1 Like