Undesirable Upgrade Behavior

The last couple firmware updates have ended in error on the step for replacing eeprom contents, loosing all my layers as a result. I didn’t select reset because that would have left the three default layers intact. In two cases I had completely different layers. All the layers were empty in one case. I used Chrysalis 0.11.6 to flash firmware 0.90.6. 11.8 for the two most recent. I missed Chrysalis 11.7.

I had backups for my layers so was able to repair which brings my second issue. Restoration did not fix my custom colours for each layer and I had to manually redo each key. I’m getting faster at that, however :sweat_smile:

Next time you flash, can you give 0.11.9-snapshot a try? It has some further bugfixes in the flashing area, and it might help your case too.

We’re still not confident in 0.11.9-snapshot’s flashing fixes (hence no release yet), but it’s worth a try, maybe. If you see a flashing fail again, either with 0.11.8 or 0.11.9-snapshot, can you make a debug bundle, and share it with us?

Going into “Report a Problem” in the main menu, and clicking “Create a Bundle” will create one (for 0.11.8, you need to be connected to the Model100 for this to work, for 0.11.9-snapshot, it can be done even unconnected). If you save that file, and share it either here, or upload it to #1060 over on GitHub, that’d help us greatly in trying to figure out what makes the process fail for people.

Will do! Reading through the #1060 discussion log looks like you may have it resolved on Linux? I’m using the keyboard on Windows but also have access to Linux at home. I’ll do the bundle on my Windows machine but if it’s helpful and there’s a safe way to downgrade firmware, I could repeat on Windows and Linux.

Worked today with the 0.11.9 release and current firmware. Posted bundle to GitHub if still needed.

1 Like