Atreus: upper layer via esc key not working

Hi folks, I received my Atreus today and I love it! I got Chrysalis installed and rearranged a couple of keys successfully.

Unfortunately, I don’t seem to be able to use the upper layer with all of the function keys as shown in the printed diagram that shipped with the keyboard, accessible from the Esc key. When I look at it in Chrysalis, it seems to just be an Esc key, and I can’t find an option that would make it also take me to layer 2. Help?

Hold down Fun, then tap Esc to get to that layer.


Thank you for clarifying! I didn’t read the key assignments carefully enough.

Is there any way to make the Esc key take me to another layer when I hold it down, kind of like how I’ve made my space and shift keys space/shift keys?

When editing the Esc key, there’s a toggle switch that says “Layer shift when held, normal key otherwise”. That should do the trick.

1 Like

The toggle I see is “Modifier when held, normal key otherwise” and it is greyed out unless you select one of the modifiers on that page. The modifier options are control, shift, alt, altgr, and gui. I don’t know what the gui key is, but I don’t think it’s a layer switch.

If you continue scrolling down, there should be a second toggle for layer shifting beneath the modifier toggle.

Hm, strange, I definitely don’t see anything like that, I can’t scroll the window down any further. I’m using the Chrysalis 0.7.9 AppImage on Pop!_OS 20.04 LTS, AMD 64-bit, Gnome 3.36.3, using Wayland. (My computer is a System76 Thelio, if you’re curious.)

Hmm, very strange. I wonder if a clean reinstall of chrysalis is what would fix this issue, though admittedly I’m the farthest thing from an expert. Hopefully someone more knowledgeable can offer more insight.

Try making the window larger. Here’s what it looks like when I do that:

From this:

to this:


Aha! You’re right, making the window larger showed me the layer shift toggle. Thank you :slight_smile:

Seems like it ought to let me scroll more if there isn’t room for all of the options, rather than simply not displaying stuff.


Indeed it should That particular bit of the UI is being rebuilt as I write, but it wouldn’t be wrong to open a bug report at


For future reference, I filed a bug: