Cannot update the layout of my model-100 anymore

Hello everyone,
I’ve just received my new model-100 which is great !
However I am facing some issue with Chrysalis.

As I ordered a set of keycaps corresponding to qwertz German layout, I decided to switch my settings>Preferences>Keyboard layout from swiss french to German. My plan was to set up some dynamic macro to reach some spécific character such as “é”, which are missing from German layout.

Unfortunately my keyboard kept part of the previous behavior, despite updating the keyboard layout in preferences from Chrysalis. It is as if the model-100 just refused to apply the changes… I tried to set back the keyboard layout to the original US layout without success. I end up trying to reset the keyboard to factory setting but it didn’t work.

Right now, when I display the current layout on Chrysalis, it shows a US querty layout but the behavior of the keyboard is still a quertz with my custom macros…
Chrysalis says that “Macro space used: 1/1024 bytes” but the macros are still active on the keyboard…

I do not really now what to try next… Would be fantastic if someone could have some insights to share about the solution…

After few experiments I realize my macro are not active and I can update the key behavior of the keyboard.
But it is as if settings>Preferences>KeyboardLayout were still set to Swiss french.

After switching settings>Preferences>KeyboardLayout to (English) US, the layout and colormap editor from Chrysalis show me a correct US keyboard at the bottom of the windows. Yet, if I set up a key to “y”, the actual behavior of the keyboard is to give me “z”. If I set up a “-” it give me " ’ " and if I set “;”, I get “é”…

So it seems it is in fact this setting “settings>Preferences>KeyboardLayout” which is stuck.

I finally realise that the keyboard does not return information identifying the letter which correspond to the key you’re pressing but it only returns its position on the keyboard. Then the corresponding letter is based on the language set in your OS system.

It means that “settings>Preferences>KeyboardLayout” MUST correspond to the language set in your OS.
Anyway, thanks for the help on the discord.